2

NOTE: I wrote this as I had problems with the PXE/Network installation, but I managed to solve it as I was writing it. This is more of a helper guide if someone else has the same problem. Also, I don't have enough reputation to post more than two links, so when I'm refering to Link x, it can be found here: http://pastebin.com/kGGLGXQz

I've recently bought my student/business PC, which is a HP ProBook 650. I would like to format my drive and install a fresh installation of Windows 7 Professional. This is what I've tried so far:

CD-ROM     -> There is none
SD-Card    -> Can't select boot from this device
USB        -> Can't select boot from this device
PXE/Network-> Having some trouble with TFTP amongst other problems.

CD-ROM: There is no CD-ROM on this laptop, and I don't have a external drive either.

USB & SD: I've tried to copy files from CD directly. I've tried using the list disk command-line approach. I've tried Windows 7 USB/DVD Download Tool. When looking in BIOS, I checked that USB Port was active, and that it was listed under boot settings as an enabled option. When opening BOOT Menu, I only see "Internal Harddrive" & "Network". I didn't find anything in the BIOS that caught my attention.

PXE/NETWORK: I followed this guide: (Link 1) On how to setup a server on another machine to be installed on my laptop. I'm using my desktop computer to set everything up. I've installed Serva, followed every instruction, and everything went exactly as the guide was written. (Although I was a little unsure about the download network drivers for client computer, but I think i found the right one).

At first I tried to connect wirelessly through LAN. When pressing esc on the laptop at startup, it will enter a pre-bios-menu, and if I press f12, it will try to do a network boot. When network boot is entered initializing network link is displayed on the screen, and 5 seconds later, it reports that no network was found. In the Serva guide (linked above), I also had the option to install via. network cable. I changed the settings accordingly and and tried again. This time it was given a MAC adress, but TFTP timed-out. Img(Link 2) TFTP Settings(Link 3). DHCP Settings(Link 4).

0

While writing this I suddenly realised that I had entered my Wireless IP as the DHCP. I then ticked Bind DHCP to this address and entered my ethernet IP (169.xx.xx.xx). Then I tried again on my client laptop, and it booted.

Now, after selecting the right OS to install, Serva tried to install the drivers I had specified on my client laptop, but every single install failed. On the left side of the screen, there was a button Open console. When in the console, I moved all of my Windows Os files to a USB(using another computer), plugged it in, and entered this command wmic logicaldisk get name, to list all drives. When I found the right one, I typed setup.exe, and everything resolved itself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.