1

My specs:

  • Intel i7 (along with Intel on-die graphics)

  • Nvidia 840M

  • 8GB RAM, 1TB HDD

It's a laptop with hybrid Nvidia and Intel Graphics. It's a HP laptop and there is no option in the BIOS to turn off the Nvidia card. It is a UEFI system if that helps. I did turn off secure boot before installation though. I'm new to Linux BTW.

Now my problems always tend to be the same. They are either one of these or a combination of them -->

  • Flickering in the screen, tearing when playing videos
  • System does not shutdown properly and the next time I boot up my battery is depleted
  • Some of the LEDs on the keyboard don't light up
  • Nvidia Card is only detected when using lspci command and never no matter what driver I install.

I've tried bumblebee but when I reboot I get a blank screen. The Nvidia settings doesn't recognize my card at all. I've tried the latest drivers from the Nvidia website and they did not work, I've tried using the noveau drivers but the tearing is just awful, I can't use YouTube properly at all.

I've tried Ubuntu 14.04, Lubuntu 14.04, Xubuntu 14.04, Ubuntu 14.10, ElemetaryOS Luna and Linux Mint 17 (Though i'm open to trying any other distro, I want Linux to work first). All of them end up with 1 or almost all of the above mentioned problems. Any help is appreciated. Thank you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.