I have a wireless network at my house. My wife's computer connects just fine to it and the internet (I am using her computer wirelessly to ask this question).

My computer will wirelessly connect to the network, but I cannot access the internet via my wireless connection. (I tried to ping google and that fails too.)

If I connect to my wired network at my house the internet works just fine.

I can also connect to other wireless networks (and through them the internet) at other places (at the in-laws and on the commuting on the train).

I know I am able to connect to the network because I am able to access my router over my wireless network. I get an IP address. Every thing seems fine. But when I try to access the internet both Firefox and IE give me the unable to connect page.

Any Ideas on what I can check to fix this?

  • which "unable to connect page" there is more than one. Can you ping What about a traceroute to – user23307 Jan 7 '10 at 4:25
  • IE says "Internet Explorer cannot display the webpage" and firefox says "Firefox can't establish a connection to the server at www.google.com." I tried to ping with the wireless connection only and it failed with "Destination host unreachable." Pings just fine when I am on my wired connection. Tracert says "1. Hardware Error." when the wireless is used but works just fine with the wired connection. – Vaccano Jan 7 '10 at 5:07
  • Check the settings in IE. See if the settings are the same on your wife's PC & yours. – Ganesh R. Jan 7 '10 at 5:11
  • Also try disabling your firewall.(Windows & third party) – Ganesh R. Jan 7 '10 at 5:12
  • Firewall is disabled and the settings are the same :( – Vaccano Jan 7 '10 at 7:04

Connect wired. Open a command prompt and run IPCONFIG /ALL or the Linux equivalent. Then connect wireless. Run again. Compare the wired/wireless DNS server entries. Compare the gateway entries. They should be the same.

  • They are the same – Vaccano Jan 7 '10 at 4:14

You can try to reset the TCP/IP stack.

Open up command prompt and run these 2 commands, then reboot:

netsh int ip reset c:\resetlog.txt
netsh winsock reset catalog
  • Thanks for the idea, but alas it did not work. – Vaccano Jan 7 '10 at 5:00

Unplug the wireless router and wait ten seconds or so and then replug it and then boot up your labtop and search for wireless and connect to yours

  • I have tried this several times. – Vaccano Jan 22 '10 at 15:32

Had this ever worked?

If you can log into your router are you able to verify that you are not running any sort of MAC filtering? You could also try and go into the network settings of your NIC and spoof your MAC address to that of you wifes laptop.

I would also remove the saved wireless internet connections you may have accumulated that refer to your home router.

If this has never worked, can you check that your router and your Wifi are running matching specs? You could possibly have a B adapter and your router could be set to allow G only or something along those lines.

  • It did used to work and does work when I have been docked in my docking station then undock with out rebooting. Once I reboot I can no longer connect to the internet. As for spoofing my wife's MAC address, I would rather just hook up a cord than do that. – Vaccano Jan 20 '10 at 5:42

Does your wired connection work?

If no, you may need to re-install drivers or reset the websocket

-If yes, then Are you running linux?

--If yes, then it is very likely that the problem is your wireless driver (i.e. my laptop only works while setting it on top of the wireless router.) There may or may not be a solution to this problem.

--If no, try to make sure your creditials for the wireless network are correct.

If all else fails reset the wireless router and set a new password/wireless name. Make sure your internet setting on your computer match your wife's computer's settings.


You may have had a Microsoft update that made come changes to your driver - see if you can roll back your computer to a time when it worked, also check in system restore and see what changes have been made to your computer.

If you have the wireless card driver, then I'd uninstall and reinstall it. By the way, which router do you have, which wireless card and driver version?


Wich encryption type do you use? Maybe the router is set to WPA or WPA2 but your PC does only support WEP.

  • If the encryption was an issue, he would be unable to connect to the router. – David Segonds Jan 25 '10 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.