3

I have a Dell Inspiron 1545 laptop running Windows 7 64-bit. It had 3 GB of RAM, and I just upgraded it to 8 GB of RAM (Crucial CT51264AC800.M16FC 2x4GB PC2-6400 DDR2-800). According to this thread, some people were able to upgrade that same model laptop to 8 GB without problems.

The computer booted up and Task Manager showed that it was using 8 GB of RAM, but the wireless icon in the system tray indicated that it couldn't connect. I tried the Windows wireless troubleshooting feature, and it said that the wireless capability wasn't turned on. But there's no wireless on/off switch on this laptop. I tried restarting Windows and the wireless still couldn't connect. Also, the Task Manager showed a svchost.exe process taking up over 50% of the CPU and over 1 GB of RAM - not sure what that was about.

So I removed the 8 GB of RAM and put the old 3 GB back in. When Windows booted up, the wireless connected fine. That means I didn't accidentally disconnect any wires on the wireless adapter.

Why won't this laptop's wireless connect when it has 8 GB of RAM installed?

  • Your inability to connect to the internet has nothing to do with you installing memory into your laptop You likely press a key combination to disable it. You try again? – Ramhound Jun 6 '15 at 22:10
  • I am not aware of any key combo that enables/disables the wireless. Why did it work again when I put the 3GB back in? – pacoverflow Jun 6 '15 at 23:12
  • I would try a process of elimination. Put the 8GB back. Does Wireless stop again? Connect with a USB WiFi. Does wireless come up? Upgrade on board wireless driver if you have not done so. – some user Jun 7 '15 at 0:23
  • @pacoverflow - You didn't answer my question, if it worked, after you restarted again and installed the other memory. – Ramhound Jun 7 '15 at 18:04
  • @Ramhound It did not work after I installed the 8 GB. I restarted with the 8 GB and it still didn't work. Then I took the 8 GB out and put the 3 GB back in - it worked after that. – pacoverflow Jun 7 '15 at 18:06
1

I downloaded and installed the latest driver from the Dell web site. Then I installed the 8 GB of RAM again. On the next bootup, everything including the wireless internet was working.

I'm not sure if installing the latest driver solved the problem though, because after installing it and rebooting, I went into Device Manager and checked the wireless driver version, and it had the same 2009 date as before. So I already had the latest driver installed. Maybe the wireless driver installation program made some other changes that fixed the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.