1

I use EduBOSS_Linux 3.0. I want to Login my BOSS Linux with root account. I try combination of default password root ---- root boss ---- root root ---- boss boss ---- boss

root ---- root is working for got root privilege during software installation but that username and password combination not work for login root account.
1) Why accurate username and password also not able to login in root account.
2) How can I login in root account of Boss Linux?
3) How can change password of root account of BOSS Linux by Admin Account? I post screen shot here
I Upload images here with description and details

  • does sudo su work? – Journeyman Geek Jun 7 '15 at 5:55
  • yes! all thinks are work. But when I try to Login with root account. It shows wrong password. Actually password is accurate. – Madhav Nikam Jun 7 '15 at 5:57
  • Have you try to change root password and try to login? – Romeo Ninov Jun 7 '15 at 6:05
  • I try to change root password I use same method like Kuser in REDhat. – Madhav Nikam Jun 7 '15 at 6:10
  • change it by login in your account, then sudo su - and the passwd – Romeo Ninov Jun 7 '15 at 6:58
1

Chances are... There's intentionally no root password. You're supposed to use sudo as needed. THIS IS A GOOD THING. It means that you're less likely to do the wrong thing as root, is more secure and sudo let's you do all the same things anyway.

If you must, sudo su (with a user who can sudo, typically the first user you add during install) will let you do things as root, including setting a root password. You don't need to /shouldn't

From the additional information in the comments, you're running a modern version of gnome, and gdm. I don't use gnome, but with that information, and that BOSS is a debian derivative, we can find an answer.

Many distros including debian, which BOSS is based off of disable root logins for graphical logins. This is a very sensible thing (and in the old days, KDE would have a red background and a bomb symbol when you did this). Once again, this is a terrible idea and you should generally not run anything as root. There's usually something that emulates sudo (gksudo?). Alternately you need to open up your login manager config file, and comment out the line that disallows root logins. I re-iterate this is a terrible idea, and you probably should not do it.

Have I said a few times its a bad idea? Good.

If you still want to do this its a file called /etc/pam.d/gdm3 and you need to comment a line out that says #auth required pam_succeed_if.so user != root quiet_success. My source suggests that you use vi, but any text editor should work

|improve this answer|||||
  • no! In BOOS root is by default password. But I again add some images of screen shot for better clarification. Here not privilege to do that. – Madhav Nikam Jun 7 '15 at 6:32
  • Updated the answer. The additional information should be in your question. If you can't upload images, just upload them to imgur, and post a link in your question to them, and someone will inline them for you shortly. – Journeyman Geek Jun 7 '15 at 7:59
  • @Journeman Geek I upload Images here – Madhav Nikam Jun 7 '15 at 10:58
2

You can try to change the password for root as seems there is no at the moment:

  1. Login as your user
  2. switch to root

    sudo su -

  3. change root password

    passwd

The open new virtual terminal and try to login as root

To troubleshooting you can check the logs in /var/log in messages or auth files

|improve this answer|||||
  • OK i try and report here. just 1 min – Madhav Nikam Jun 7 '15 at 7:21
  • I change password. But still not able to login in root. – Madhav Nikam Jun 7 '15 at 7:24
  • Check my edited answer – Romeo Ninov Jun 7 '15 at 7:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.