3

I've set up a dev-enviroment on Debian 7 and installed the following services:

  • Apache
  • Bind9

I have one site that is reachable through "asix.debian.local". I've set up the zone and added NS and A registry to the db.debian.local file.

Everything is working, this is the response I get with curl:

"curl asix.debian.local" Apache default

It works!!

Aquest es la pagina de benvinguda de ASIX

So I guessed I got everything up and working, but when I type in the same URL in browser, I get "Server not found error - Iceweasel can't find the server at asix.debian.local."

Only nameserver in /etc/resolv.conf is the local IP of the server.

Why can't browser reach the website if curl did?

Any help is appreciated.

Thanks

  • Are you use browser on the same machine you use curl? – Romeo Ninov Jun 7 '15 at 18:21
  • Yes, both on Debian 7, it really makes no sense. – Borjante Jun 7 '15 at 18:22
  • I mean on the same machine, no the same OS – Romeo Ninov Jun 7 '15 at 18:23
  • Yes, they are.. – Borjante Jun 7 '15 at 18:25
  • What you have configured in /etc/nsswitch.conf? Did you try to add record in /etc/hosts? – Romeo Ninov Jun 7 '15 at 18:26
2

For such case please add line in /etc/nsswitch.conf

hosts: files dns mdns4_minimal [NOTFOUND=return] mdns4

to be

hosts: dns files mdns4_minimal [NOTFOUND=return] mdns4
  • Did it sir, still the same, curl works, ping works, wget works, just the browser ain't finding the server. It's really strange :S – Borjante Jun 7 '15 at 18:34
  • 3
    Please restart the browser and try again, because some time browser cache DNS requests – Romeo Ninov Jun 7 '15 at 18:35
  • 1
    I feel so stupid... That's what happens when you don't stop to think. I knew it was a stupid thing. Thanks a lot, it works now – Borjante Jun 7 '15 at 18:37
  • 2
    @Borjante, there are no stupid questions, there can be stupid answers :) And sometime everyone just stuck – Romeo Ninov Jun 7 '15 at 18:40
  • 1
    You are completely right – Borjante Jun 7 '15 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.