1

I am testing on a private network and want to use Chrome to load a web page. There is no DNS access on that machine.

Chrome will not let me load the page because of something like "The server XXX can't be found, because the DNS lookup failed."

How can I stop Chrome from needing a successful DNS lookup?

I am giving it an IP address, not a name to be looked up.

  • does the page you are loading refer to any external references by url with DNS names? – Frank Thomas Jun 8 '15 at 15:15
  • In this case it is an IPv6 address, here is the link-local URL I am using: http://[fe80::4026:828e:cd9d:d4a0]/ and again that is a local address – Solx Jun 8 '15 at 15:15
  • The page is hand crafted, and quite empty, no links to anything in it, very bare bones. Note that I can reach it from IE – Solx Jun 8 '15 at 15:16
  • 1
    This question is a possible duplicate of this question. Its now called "prefetch resources to load pages more quickly" despite the comments saying it was removed. – Ramhound Jun 8 '15 at 15:56
  • Don't specify the brackets. – LawrenceC Jun 9 '15 at 17:34
0

Chrome uses DNS caching and prefetching to speed load times. Here is a question about clearing the DNS cache. You can disable the cache by opening Settings->Advanced Settings->Privacy Settings and unchecking "Predict network actions to improve page load performance."

Alternatively, you can edit your hosts file to allow the DNS lookup to succeed. On a Windows machine, edit C:\Windows\System32\drivers\etc\hosts and add a line containing the IP address and hostname (192.168.1.2 myhost.mydomain.com). On a Linux or Apple machine, edit /etc/hosts, adding the same info.

  • Not having any luck adding it to the hosts file, but it is an IPv6 address, so not sure of the format, I added both of these lines:\ fe80::4026:828e:cd9d:d4a0 test-ap \ [fe80::4026:828e:cd9d:d4a0] test-ap2 – Solx Jun 8 '15 at 16:15
  • There is no need to edit your hosts file when navigating to an IP address. This is not the cause of the problem. – Kevin Panko Jun 9 '15 at 17:24
  • Just noticed the update to the question, I'll edit this answer tonight. – ztk Jun 9 '15 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.