3

While tweaking around in the "Manage 3D Settings" and in the "Global Settings", I wanted to play around with some of the options, like change my performance mode to single display vs multiple display. When I apply the settings, an error message comes up saying, "Access Denied. Failed to apply selected settings to your system". Does anyone know why that is?

5
  • What version of the Nvidia drivers do you have? – bfhd Jun 9 '15 at 1:41
  • @bfhd Newest drivers. – Mr McClean Jun 9 '15 at 18:12
  • Which Windows/OS? – Sharad Gautam Jun 11 '15 at 4:54
  • 1
    Which OS, which drivers (DirectX, nVidia), what video card, what monitor... Can you please include information when you ask a question? – Everett Sep 14 '15 at 3:49
  • In my case the last folder in the directory path C:\ProgramData\NVIDIA Corporation\Drs was missing. After creating the missing subfolder Drs I longer got the error. – E. van Putten Jul 14 '20 at 14:57
3

C:\Program Files\NVIDIA Corporation\Control Panel Client

Right Click On nvcplui.exe and Run As Admin

Thats work for me

2

I haven't experienced this problem, but there are several possible solutions in this reddit thread: https://www.reddit.com/r/techsupport/comments/37j056/nvidia_control_panel_access_denied_failed_to/


Here are a few:

  1. I had the exact issue after latest update (today) and I've fixed it by going to "C:\ProgramData\NVIDIA Corporation\Drs" -> right click ->properties -> Previous Version (assuming you're system protection/system restore on c:) and restored the all the files with the most recent version... that's how I've solved the problem. In case people want the pre-update files, I've uploaded'em: http://www.2shared.com/file/vFlksc1J/Drs.html -> the go into the following dir: "C:\ProgramData\NVIDIA Corporation\DRS" https://forums.gefrce.com/default/topic/836061/geforce-experience/-solved-acces-denied-failed-to-apply-selected-settings-to-your-system-issue/post/4543709/#4543709

  2. I fixed the error by removing all nVidia software and drivers, reinstalling the 350.12 Driver and PhysX ONLY (no 3D drivers, no GFEX), then downloading the separate GeForce Experience package and installing that afterwards. Now I have access to my settings again, although all my presets and custom resolutions were reset.

    1. I think I finally found the solution: uninstall all the nvidia drivers, > everything nvidia including the nvidia experience software and restart. Then do a search for the drivers and manually download them but do not download the experience software (choose custom install to uncheck the option). I am now able to select my nvidia gpu as default and it sticks (closed control panel and reopened to make sure it was stuck on nvidia and not auto detect). Just tested it on the game I was having a problem with and holy moly, night and day difference. Hope this helps you all!

Good luck!

1
  • Doing a clean install fixed this issue. ;) – Little Helper Jun 26 '15 at 21:06
0

In my case, where I have a notebook with NVIDIA Optimus, I wasn't able to change some configurations until I pressed the "VGA Button" which effectively "turns on" the Nvidia card.

Not the answer you're looking for? Browse other questions tagged or ask your own question.