I have a table in a document, in Word 2010.

How can I copy and paste a cell? The whole cell, not its content.

I copy a cell, it has a grey background with hatching ("shading"). Then I paste it over some other cell in my table. Word stupidly loses the formatting. The destination cell is still white.

I have tried the various "paste options" that are proposed at right click. To no avail.

Is there a solution?

Thank you.

[Edited: link to image.]


You need to copy the content of the cell not the cell itself. This takes a bit of practice and is mightily annoying!

If you see the grey, you've selected too much. The easiest way is to click in the cell and press ctrl-a then copy. If the paste doesn't do what you expect, check what you've set the default paste to. You can, of course, control the paste type after you paste or you can do a paste special.

UPDATE: Oops! Never noticed that ctrl-a selects everything and I've been using Word for decades!

As an alternative. Click at the start of the cell, then shift-end. Then still holding down shift, use the back arrow to go back one. That last part is important as it changes from selecting the cell to selecting the content. I actually tried it this time so hopefully no more embarrassments.

UPDATE 2: Now that we know you want to copy the format and not the content, we can focus on the best way to do that. Which is to create a style and apply the style to all the cells you want to have the same style. You can also assign a keyboard shortcut to a style to make things even easier.

UPDATE 3: Just to be absolutely clear. The format for a paragraph is contained in the (normally hidden) end paragraph mark. It is this that is selected when you do shift-end, turn on visible paragraph marks to see this more clearly. In a table, this changes to a cell marker rather than a paragraph on. To copy the formatting for a paragraph (or cell), you have to include that mark in your selection.

To Turn a formatted cell into a style, show the style panel, select the cell, click on the "New Style" button. The resulting new style dialogue should already be formatted as per the cell. Give this a name and set the shortcut. Save the style to normal.dot if you want it always available otherwise save it to the document. Now in any cell, simply select your style (no need to select the cell) and the cell will be formatted accordingly.

The "extra thought" is a one-off and need never be repeated if you save the style in normal.dot (the default Word template).

  • 1) My cell is empty! But I had tried with some text in it, I did not find a solution. When I write some content in the cell, and I copy it, then I get the content pasted, not the cell, and not the format. – Nicolas Barbulesco Jun 12 '15 at 13:27
  • 2) I click in the cell. I press Ctrl A. This selects my whole Word document, that is the whole table and more. – Nicolas Barbulesco Jun 12 '15 at 13:28
  • Why are you copying an empty cell? The rest I've updated. – Julian Knight Jun 12 '15 at 13:43
  • Julian, regarding your variant : 1) The last part is important indeed, it changes from selecting the cell to selecting nothing ; I get back the blinking cursor. 2) After I write some text in the cell, your technique copies the content, but then pasting pastes only the content, not the cell, so I don't get the format of the cell. – Nicolas Barbulesco Jun 15 '15 at 14:57
  • 1
    Please see the next update – Julian Knight Jun 16 '15 at 18:42

After trying and playing with the same subject find out the very strange behaviour of Word:

  1. select cell
  2. copy cell
  3. move to another cell
  4. paste (special - cell with formatting)
    *) result - the content is copied, but the format (shading, borders still old properties)
  5. paste (special - cell with formatting)
    *) simply repeat the paste command second time
    **) result - formatting is also copied, new cell has new properties (shading, border style)

I assume that this is a strange feature of Word.

  • In word 2007 that option is not in paste special? – Piecevcake Sep 14 '20 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.