1

It was very comfortable to use Greenshot for asking questions on SE since it could upload to imgur, which is the same hosting, used with SE.

Unfortunately, it started to respond with error 403 Forbidden on upload.

Is it possible to fix?

enter image description here

UPDATE

Tried to capture access to URL http://api.imgur.com/2/upload.xml and found response:

<error>
<message>API limits exceeded</message>
<request>//2/upload.xml</request>
<method>get</method>
<format>xml</format>
<parameters/>
</error>

UPDATE 2

I found that I still can use Greenshot from notebook. Notebook is behind the same NAT, so blocking issues are unprobable.

  • Can you upload to imgur directly using a browser? – Karan Jun 9 '15 at 12:06
  • Yes, I can, I have just uploaded screenshot via saving to file first. – Dims Jun 9 '15 at 12:07
  • 1
    Then imgur might have changed something or possibly even deliberately blocked the app. Report it to the Greenshot developer as a possible bug. – Karan Jun 9 '15 at 12:10
0

When using anonymous access to Imgur, you're affected by the global API limit for Greenshot. Which is usually depleted due to the large amount of Greenshot users.

You have to use an Imgur account with your own credentials to make the plugin work again.

  1. Go to https://imgur.com and create an account.

  2. Open the Imgur setting for the Greenshot plugin from the Greenshot application context menu of the icon in the notification area:

    enter image description here

  3. Disable anonymous access:

    enter image description here

  4. You will now be guided through the OAuth2 process and your Imgur account will be used for future uploads.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.