0

I'm using OSX 10.10.1 and I'm trying to concatenate .mp4 files with the ffmpeg demuxer. Below is what I enter and the error I get. Please help! I'm not a programmer but I had the demuxer working on my laptop (OSX 10.8.4). Not sure why it won't work on my desktop:

Emmas-Mac-Pro:~ EmmaMH$ ffmpeg -f concat -i /Users/EmmaMH/Documents/Dance\ Afire/20150609/Cam1/Cam1.txt -c copy /Users/EmmaMH/Documents/Dance\ Afire/20150609/Cam1/Cam1A.mp4
ffmpeg version 2.6.3 Copyright (c) 2000-2015 the FFmpeg developers
  built with Apple LLVM version 6.1.0 (clang-602.0.53) (based on LLVM 3.6.0svn)
  configuration: --prefix=/usr/local/Cellar/ffmpeg/2.6.3 --enable-shared --enable-pthreads --enable-gpl --enable-version3 --enable-hardcoded-tables --enable-avresample --cc=clang --host-cflags= --host-ldflags= --enable-libx264 --enable-libmp3lame --enable-libvo-aacenc --enable-libxvid --enable-vda
  libavutil      54. 20.100 / 54. 20.100
  libavcodec     56. 26.100 / 56. 26.100
  libavformat    56. 25.101 / 56. 25.101
  libavdevice    56.  4.100 / 56.  4.100
  libavfilter     5. 11.102 /  5. 11.102
  libavresample   2.  1.  0 /  2.  1.  0
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  1.100 /  1.  1.100
  libpostproc    53.  3.100 / 53.  3.100
[concat @ 0x7fae9180da00] Impossible to open '/Users/EmmaMH/Documents/Dance Afire/20150609/Cam1/‘/Users/EmmaMH/Documents/Dance Afire/20150609/Cam1/GOPR0935.MP4’'
/Users/EmmaMH/Documents/Dance Afire/20150609/Cam1/Cam1.txt: No such file or directory
  • 1
    Do you have the list of the files you're trying to concatenate in Cam1.txt? In that case it would be helpful to post the file contents as well. – Dmitry Grigoryev Jun 10 '15 at 6:36
2

I suspect your text editor had “smart quotes” enabled when you created your Cam1.txt file list, so all those…

file '/path/to/file.mp4'

…lines ended up like this…

file ‘/path/to/file.mp4’

…which ffmpeg misinterpreted as relative paths with funny characters in them.

Go through your Cam1.txt and make sure all your paths are encased in old typewriter/ASCII-style 'straight quotes', not ‘curly quotes’.

0

I just ran into this same error message "Impossible to open..." with a doubled path. I eventually figured it out.

The issue is that the paths listed within your text file are interpreted by ffmpeg as being relative to the location of your text file. (In particular, the paths listed are not relative to the current working directory.)

Thus, for example, if the video files you're trying to concatenate together are in the same directory as your text file (but different than the current working directory), then the paths listed in your text file should simply be the video file names without any preceding directories.

Hope this helps someone in the future.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.