1

I use a CentOS virtual machine on VMWare Workstation. I recently tried to increase the system hard disk memory for CentOS by tweaking the VM settings on VMWare Workstation. After that, I tried to follow the steps as listed here: http://kb.vmware.com/selfservice/search.do?cmd=displayKC&docType=kc&docTypeID=DT_KB_1_1&externalId=1006371

However, when I try to list the Volume Groups using vgdisplay, it shows that there are no Volume Groups. How do I resolve this issue?

terminal on typing vgdisplay:

Incorrect metadata area header checksum on /dev/sda4 at offset 4096

No volume groups found

The new partition to be added is /dev/sda4

terminal on typing fdisk -l :

Disk /dev/sda: 128.8 GB, 128849018880 bytes

255 heads, 63 sectors/track, 15665 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk identifier: 0x0007bec8

Device Boot Start End Blocks Id System

/dev/sda1 * 1 39 307200 83 Linux

Partition 1 does not end on cylinder boundary.

/dev/sda2 39 2354 18598912 83 Linux

/dev/sda3 2354 2611 2064384 82 Linux swap / Solaris

/dev/sda4 2611 15665 104857592+ 8e Linux LVM

I cannot figure out where I am going wrong. Please help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.