1

I've got an issue with a firmware Intel RAID0 array. It consists of 2 disks 500 GB each. The second disk has several bad sectors, and I can't remap or hide them (they are 8 LBAs or 4096 bytes). I tried Victoria and MHDD but to no avail: Victoria says "No DRQ" when sees these 8 LBAs, MHDD just hangs. In any OS and in any program HDD hangs when tries to access these faulty 8 LBAs.

Usually when I had issues with my RAID0 before, I just deleted the RAID and recreated it with the same settings in an Intel configuration utility (before loading operating system), booted into Windows, ran TestDisk, it found deleted partitions, recreated them, and everything was just fine. But not this time.

If I recreate partitions and reboot, Windows hangs when I try to boot with this array and I can't see the partitions. If I unplug the array or disable RAID mode in BIOS Windows boots ok. If I recreate the array and don't recreate partitions, Windows boots ok and sees the RAID as a single uninitialized 1000 GB volume. I can run data recovery software and I can even see the first NTFS volume and files in this software. However I can't see the second 900 GB NTFS volume and that's very sad.

Now I recreated the array in Intel tool, ran PartedMagic, but it doesn't see the array, only 2 disks 500 GB each (/dev/sda and /dev/sdb). When I launch dmraid it reports the array is broken (ERROR: isw: wrong number of devices in RAID set "isw_eeeffhddde_MY_RAID" [1/2] on /dev/sda ) and "status : broken". I doubt it is really broken, because as I said earlier Windows can see the RAID in data recovery programs.

I know I should have done backups :) But anyway, any suggestions how to save at least some data?

1

You said you can run recovery software, Is all the data you need able to be recovered this way? If so you should probably just migrate off of these disks.

Have you run SMART checks on the disks? remaking the RAID with bad disks would just be asking for problems down the line.

I'm unfamiliar with Intel Raid, but you could try checking for alternative superblocks which may contain the seemingly corrupt partition information.

Also, using RAID0 with important data and not having any back ups is a very bad idea, I hope you learn from this mistake for the future!

  • I can run recovery software, but it can see only the first 100 GB volume (but not the second 900 GB). This is strange because TestDisk sees both partitions correctly and can recreate them (this results in Windows hanging up after reboot though - it tries to access those faulty 8 LBAs and I assume that unfortunately they are part of something important - e.g. MFT). – FelisManulus Jun 10 '15 at 8:41
  • SMART was ok, but actually the disk is faulty. It definitely has bad blocks. – FelisManulus Jun 10 '15 at 8:44
  • Have you tried using the TestDisk 'Repair MFT' to try restoring it from it's mirror? – Jack Jun 10 '15 at 9:02
  • No, but I'll give it a try after doing complete backup of both drives with dd – FelisManulus Jun 10 '15 at 9:07
1

OK, maybe my experience will be useful for someone. I did the following:

  1. Swithed to IDE mode, cloned all sectors from RAID member 1 from sector 0 to the first bad sector to an image file img01-1 using WinHex (you need to select physical device).

  2. Created a 4096-byte file and filled it with zeroes (I had 8 bad sectors 512 bytes each). I named it img01-2.

  3. Copied the rest of RAID member 1 to image file img01-3.

  4. Concatenated the 3 files to img01.

  5. Cloned RAID member 2 to img02 file. img01 and img02 were exactly the same size.

  6. Then i borrowed 2 HDDs (they were exactly the same model and size as my old disks, I don't know if it matters) and wrote the image files to them.

  7. Disconnected the old disks, connected the new ones.

  8. Swithed to RAID mode in BIOS, Intel config util reported 2 "Unknown disks", I selected "Reset Disks to Non-RAID", and recreated the RAID using exactly the same settings as before.

  9. Launched TestDisk, it detected my partitions and asked if I want to save partition information to disk. After reboot I saw all my files intact (I launched chkdsk but no errors were found).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.