5

One of the partitions on our Server 2003 R2 server recently ran out of free disk space.

After freeing up a significant amount of free space (20 GB, which only corresponds to 1.37% of the partition - maybe not enough?), I noticed that the "Compress contents to save disk space" option was greyed out for every file and folder on that partition:

enter image description here

Does there need to be a certain percentage of free space on the drive, rather than absolute amount of free space? Or maybe running out of free space caused it to disable this option and it won't return until the system is rebooted?

Just to clarify: this option used to exist on this partition at one point and the partition was, and still is, NTFS formatted. All other NTFS partitions on this drive do have a "Compress drive to save disk space" option in the "General" tab but that option does not exist for this particular partition.

I haven't seen this before and couldn't find any information online about it.

Does anyone have any idea what could cause this to happen and how can go about fixing it?

4
  • Are you sure the account that you are using has "Full Control" access to that folder ? AFAIK this is a requirement for the option to be available.
    – Tonny
    Jun 10, 2015 at 13:57
  • This is a server so I'm logging in as domain admin. Jun 10, 2015 at 13:59
  • That doesn't necessarily mean you have full-control. It only means you can take control if you need it. Check the "effective permissions".
    – Tonny
    Jun 10, 2015 at 14:04
  • Aha. Good point. I just checked my effective permissions for this partition and I do indeed have full control. Hmm... Jun 10, 2015 at 14:06

1 Answer 1

6

What is the cluster size? NTFS compression only works on volumes with a cluster size of 4k or less.

http://blogs.msdn.com/b/ntdebugging/archive/2008/05/20/understanding-ntfs-compression.aspx

Native NTFS compression does not function on volumes where the cluster size is greater than 4KB, but sparse file compression can still be used.

5
  • Good one... Especially since he mentions that it is a HUGE volume.
    – Tonny
    Jun 10, 2015 at 14:01
  • But normally the cluster-size isn't changed and it used to work before. Could be someone used fsutil to disable compression. (Do "fsutil behavior query disablecompression" to check that.) Check clustersize with "fsutil fsinfo ntfsinfo <drive>".
    – Tonny
    Jun 10, 2015 at 14:10
  • 20 GB as 1.37% of the total is only a 1.5 TB partition. support.microsoft.com/kb/140365 The default cluster size is 4k up to 2TB, but I agree it's not common to change it later.
    – jimp
    Jun 10, 2015 at 14:13
  • This server is virtualized - maybe I should've mentioned it before but I wasn't sure if it was relevant. Does cluster size matter with VMs the same way as with physical machines? Jun 10, 2015 at 14:20
  • I do not think that should matter. Checkout of that MSDN link above. There is a screen shot that looks like yours with the checkbox grayed out due to a sparse file getting copied manually. Perhaps your issue is related. I'm sorry, I really don't know why yours is happening. I did some searches and didn't turn up much else.
    – jimp
    Jun 10, 2015 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.