I just installed the new OS El capitan 10.11 and discovered that intelliJ isn't working on it.

When I launch it, I get this error:

"This application requires the legacy Java SE 6 runtime which is unavailable for this version of OS X."

I'm guessin that Java hasn't been set up properly yet. Does anybody have any ideas on how I can make this work?

  • 1
    You can properly setup Java. Based on the error it looks like its looking for a legacy installation and 10.11 isn't going to have an unsupported legacy version of Java. What version of IntelliJ are you using that still requires that legacy version of Java? – Ramhound Jun 10 '15 at 16:10
  • Running intelliJ 13. Not sure why it would require a legacy. Is that something I can change? – denislexic Jun 10 '15 at 16:18
  • As of 2013 the installer still required 1.6 so try adding 1.6 and see if it works. Also related – Ramhound Jun 10 '15 at 16:23
  • Can't install 1.6 (official Apple java), it's not supported in 10.11 :( – denislexic Jun 10 '15 at 17:21
  • 2
    Java 6 for El Capitan: support.apple.com/kb/DL1572 – nschum Jul 23 '15 at 12:42

If you did an upgrade of an 10.10 install where everything still worked fine (and where the Apple-supplied java 6 runtime was installed), the following solution might work. I had the same problem as you had, and this solved my issues:

  1. Quit IntelliJ and go to the Applications-folder in Finder
  2. Right-click the IntelliJ.app and choose: Show package contents
  3. Open the Contents-folder (this was the only file/folder in my case)
  4. Open the Info.plist file using a text-editor of some kind (TextEditor should do the job, but I prefer using Sublime for such tasks).
  5. Find the following tag:

  6. Remove 1.6*, from the string-tag, so it becomes:

  7. Save the file, and try to start IntelliJ again.

As I said, this seems to work for me. I do have to note that I am using IntelliJ 14, but I think this process should work for 13 as well.

Also, when a more permanent solution from Apple comes out, it might be a good idea to undo these steps (just add the removed text again) or reinstall IntelliJ completely.

  • 1
    Awesome, worked! I changed it to 1.8* and worked like a charm. Thanks! – denislexic Jun 15 '15 at 12:45
  • Does not work for me at all ... edited the file, still the same blocking dialog (idea 14) – Jan Galinski Oct 4 '15 at 7:08

I simply reinstalled Java 6 from this Apple link https://support.apple.com/kb/DL1572?locale=en_US and IntelliJ 14 was able to recognize it. This also allows me to continue using Java 1.6 in Intellij.

More here: https://intellij-support.jetbrains.com/hc/en-us/articles/206827627-IDE-doesn-t-start-after-updating-to-Mac-OS-Yosemite-or-Mavericks

From Jetbrains support:

JDK 1.6 is required to run and may be missing on your system. Please install Apple JDK 1.6. There should be a window with the suggestion to install Java when you start the product for the first time, but it could be hidden by other application windows.

  • Welcome to Super User! Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Oct 29 '15 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.