I have already booted up an OS but find it too slow to work on. Is there a way to increase the RAM which was allocated to it initially?

3 Answers 3


Pretty easy to do.

  1. Power down the VM (the guest has to be off, not just not running but with a saved state).
  2. Discard 'Saved State'
  3. Open the VM's settings.
  4. Open the System tab.
  5. Change the "Base memory" value to however much RAM you want.

Remember, the VM will reserve all the RAM you allocate to it on your host, so make sure you have enough spare RAM. Most modern OSes will deal with the amount of RAM changing just fine, but you may still run in to trouble, so make a snapshot first.

  • 4
    Many settings are greyed out and cannot be altered. One must first do "Discard Saved State". This is safe because I shut the VM down previously. After that the RAM can be expanded.
    – mark4asp
    Jul 10, 2017 at 18:49
  • With VirtualBox 5.2.4 I didn't need to discard the saved state. I just followed the list, except for point 2, and it worked. So maybe they changed it in recent versions. Aug 21, 2018 at 18:47
  • Fabio's comment caused me to investigate more. I was seeing all the VS settings greyed out and would have had to discard saved state to edit them. So I launched my VM and then in then in the VM's OS I properly shut down the OS. Once I did that then I could edit the VM's settings, they were no longer greyed out and I didn't need to discard saved state. So that seems to be the key. If you closed the VM's window without properly shutting down the OS in the VM the settings will be greyed out. But if you properly shut down the VM's OS, they will be editable.
    – RonC
    May 19, 2021 at 13:51

In addition to Dennis M, to change Vm machine memory settings via command line, I used :

vboxmanage modifyvm "Centos7_Vanila" --memory 1000
  • Where "Centos7_Vanila" is my VM name.
  • To Get your imported / listed VMs run following command :

    vboxmanage list vms
  • 1
    Just a note: the default unit seems to be megabytes and it will fail if you try to add the unit like --memory 1000M.
    – Luc
    Mar 26, 2021 at 16:41

There is a fast way in terminal, I named the virtual machine "Android 8.1 Oreo", so just modify that on the following command:

vboxmanage modifyvm "Android 8.1 Oreo" --vram 256

I had a maximum of 128.

  • 1
    The question is not about VRAM.
    – gronostaj
    Dec 23, 2019 at 13:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .