In an attempt to get a WD USB HDD to work I followed a suggestion to uninstall all devices of type Mass Storage using USBDeview. Now, Windows 7 does not show any mass storage device, even the ones that worked previously. For example, a connected USB pen drive is listed in USBDeview as not connected:

Screenshot of USBDeview

In the Device Manager it appears with an exclamation mark:

Screenshot of Device Manager

It is not shown at all in Disk Managment.

I already tried reinstalling my ThinkPad T420si's Intel chipset drivers, but to no avail.

How do I get USB mass storage to work again?

up vote 4 down vote accepted

Someone pointed me to a post in sevenforums.com by Difusal. After following the steps in the post, I deleted the entry with the exclamation mark in the Device Manager, then replugged the device. The mass storage driver installed automatically, and the drive is now detected.

Steps, copied from the aforementioned forum post, reformatted and with typos and spelling corrected:

  1. Open Windows Explorer.

  2. Go to C:\Windows\System32\DriverStore.

    You will have a couple of folders and files.

    You will have *.dat files and another file named: infcache.1

  3. Right click every file (don't touch the folders!) and choose properties.

  4. Go to the Security tab.

  5. Click Edit.

  6. Choose your account and check the box: Full Control (see ss)

  7. Click OK.

  8. Repeat for every file.

  9. Select all the files (*.dat and infcache.1).

  10. Press Shift + Del.

  11. Click OK.

  12. Now, go to C:\Windows\System32\Driver Store\File Repository.

  13. Search folders containing usbstor.inf.

  14. Open it (if you have more than one, choose the most recent).

  15. Copy usbstor.inf and usbstor.PNF.

  16. Paste those two files to C:\Windows\inf.

  17. Reboot your PC and voilà! :b

Find the hardware ID of the device by right clicking on the device selecting properties and navigating to Details then hardware ids in the drop-down menu.

http://i.stack.imgur.com/xRfah.png

Take the top one and search it on Google preferably. See if you can find the corresponding device or if your lucky, the recommended driver for the device and download that from the support page of lenovo.

  • How do I help people then? I cant comment so I cant help before I post on my own questions enough? – Xander Jun 11 '15 at 0:18
  • Essentially what I have to do is post a full response instead of a request. So I cant do tiered support until I hit 50 but I can post simple fixes in the answers category. I edited my earlier post to show a full response, does that comply with your rules? – Xander Jun 11 '15 at 0:41
  • Yes. And they are not my rules. They are the community rules. I've inlined the image for you. – DavidPostill Jun 11 '15 at 0:43
  • You are welcome. It won't take long to get 50 rep if you keep writing good questons and answers. – DavidPostill Jun 11 '15 at 0:44

I had the same issue with an "WD Elements 2 TB" disc. The issue was that my USB Hub didn´t produce enough power. In the manual WD said I might need a special Y-Wire which isn´t included. But my notebook vendor (HP) said I need to use another USB port (one with a small flash beside the USB icon). This special USB port offered more power and using that USB port solved my issue.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.