2

I'm using a Lenovo Y-50 Touch with Windows 8.1 Update 1.

I've noticed that in the past couple of weeks, I'm having issues with getting my laptop to sleep when I close the lid. I first noticed the problem because my battery was dying while the laptop was in my bag, but I don't have an exact date to correlate to any software updates.

The screen will darken immediately, like it's supposed to, but the back light on the keyboard and the internal fans will stay on.

Opening the lid slightly and closing it a second time will do the trick: the lights and fans turn off, and I get the expected battery life.

Further information:

I had the screen replaced (a second time) a couple months ago, so at first I thought there might be a hardware switch issue, but since it turns the screen off correctly, and works the 2nd time, I no longer think it's hardware-related.

I run all my machines with the powercfg.exe /hibernate off setting. So, I know I'm running sleep settings and not hibernate settings (I do this intentionally to save on SSD space). It shouldn't make difference, but I figured I'd mention it just in case.

As I finished writing this, I realized that I recently had a Windows Update message mentioning that there was now an incompatibility with my Power Management software drivers. Windows can't find new ones when I try to search through the Update window. I've so far been assuming it's been talking about the Lenovo Power Management software, which hasn't been updated since 2015-03-17, while I've only been having the issue since maybe 2015-05-15 at the earliest (AFAIK).

Update: I reinstalled that same version of the LEM software. It fixed the driver issue, but not the lid closing issue. I double-checked the power settings, and the LT is set to sleep when lid is closed for both Plugged In and On Battery. The Lenovo software has no options for changing these settings, so there's no conflict there.

Update 2: Well, this is ridiculous. It worked fine for a period, but as of tonight it's back to not working again. Sleep will only activate if 1) Close the lid, which shuts off the screen 2) Open the lid so the screen turns back on 3) Close the lid again.

1

Reinstalling the LEM (Lenovo Energy Management) software did not initially seem to do the trick. I rebooted the laptop a few times afterwards, but the problem persisted for a couple more days.

Then, it cleared up on it's own. I had to do some more reboots due to Windows updates, and it seems to have worked after that. None of the updates were hardware/driver-related.

So, I'm assuming that reinstalling the Energy Management drivers did work, but for some reason they weren't loaded properly during the initial reboots.

If you're like me, and you rarely reboot your laptop, try rebooting more often to get those new drivers to load up. If the problem still persists, try:

  1. Uninstalling/removing the existing drivers
  2. Reboot
  3. Reinstall the new drivers
  4. Reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.