1

I have an HP ENVY TouchSmart Ultrabook 4-1119tu that came with Windows 8.1, and I'm trying to add Debian Jessie in a dual-boot configuration.

PREPARATION

I made space on my hard-drive using a partition utility from Windows 8.1 to shrink the Windows 8.1 partition. Next I created bootable USB media from the Debian ISO I downloaded, and set the UEFI/BIOS settings to boot from USB.

RUNNING DEBIAN JESSIE INSTALLER

Install reported a few devices that required non-free drivers (firmware-realtek and firmware-iwlwifi), but I tracked those down and added them to the USB media.

When I get to the point where the installer is going to partition some or all of the hard drive for linux, only the USB media is listed; the HDD doesn't seem to be getting detected at all.

I'm wondering if that's because this laptop comes with a combination HDD with 32GB SSD (a.k.a. "Intel Smart Response and Rapid Start Technology with 500 GB SATA and a 32GB mSATA")?

This is the point where I get stuck. I've tried switching on Legacy Support in the BIOS setup, but it makes no difference; I get stuck at the same point in the install process.

SIDE NOTE / RANT

There were surprisingly few options in the BIOS setup, and after researching InsydeH20 3.7, it seems that their setup utility has two modes; locked and unlocked. In locked mode a whole bunch of options are hidden. To access the full set of options in unlocked mode, I assumed there would be a secret password or a magic key sequence. Nope.

According to my research, unlocking involves something on the order of a firmware update (and even then, the only options seemed to be some third-party's modded version). I visited both HP's and Insyde's web sites, but no mention of unlocking your BIOS anywhere. I thought I was the owner of this laptop after I paid for it, but apparently I was mistaken. WHAT... THE... HELL?

BACK ON TOPIC

So, I'm out of my depth and out of ideas. Is this just a matter of the installer lacking the right drivers to recognize my HDD, or is this something that can only be accomplished by changing some BIOS option that I can't get access to?

Surely it can't be impossible to install another OS besides Windows on this laptop?

6
  • 1
    Did you disable Secure Boot in the BIOS? This is exactly what this option is for, preventing people from installing OSes without some sort of certificate. I understand Ubuntu has it, but I do not keep trck of this since I always use Linux only. Jun 11, 2015 at 5:35
  • @MariusMatutiae - Yes. Before I did that, it gave me some error message instead of running the Debian installer. Jun 11, 2015 at 17:01
  • 1
    I have no experience with this, so I will not offer you any guidance, but I found this Web page, ubuntuforums.org/showthread.php?t=2020155 where your problem is solved. Jun 11, 2015 at 17:12
  • The hardware you own, the firmware you do not.
    – Moab
    Jun 12, 2015 at 1:39
  • @Moab - Sure, but someone decided that as the owner of this laptop, I shouldn't be allowed to access all but a few basic configuration settings. Jun 12, 2015 at 4:28

1 Answer 1

0

OK, MariusMatutiae pointed me in the right direction. The actual problem was that the Intel Smart Response HDD + SSD combo was set up in a fake RAID configuration. Never occurred to me to look in Windows 8.1 for a way to disable it, but that's where it was (search Apps for keyword 'Intel').

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.