2

I am using Lenovo Thinkpad E430.

I have installed Windows 8.1 Pro 64 bit

My battery charges up to 46%, and then it is showing "plugged in, but not charging".

I tried many possibilities.

1. Uninstalled AC Adapter control 
2. Removed battery for some time
3. Shutdown, Connected AC adapter, Uninstall AC Adapter control, Connect Battery
4. Reset Gauge on energy management (It takes long time to reset).

But these did not fix the problem.

Can some one point out the solutions for this one?

marked as duplicate by Ƭᴇcʜιᴇ007, Dave, Ramhound, Karan, fixer1234 Jun 12 '15 at 2:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

This is by design on some Lenovo laptops, including yours. Charging your battery to about 50% will increase its lifespan compared to a full charge. You should keep this setting if your laptop is on mains power most of the time, and when it's not, you don't need it to work on battery for a long time.

In order to disable this setting:

  1. run Lenovo Power Manager (usually a double click on the battery icon will do)
  2. switch to advanced mode and go to Battery tab
  3. click "Battery Maintenance..." button
  4. select "Always fully charge" option

If you don't have or don't use Lenovo Power Manager, you should be able to set charging thresholds via the registry. For Windows 8, the procedure is described in the following topic on Lenovo forums:

Find the registry key [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Lenovo\PWRMGRV\Data]

You should see 4 entries that are currently set to 0: ChargeStartControl, ChargeStartPercentage, ChargeStopControl, ChargeStopPercentage.

The first 2 entries, ChargeStartControl and ChargeStartPercentage, change the starting charge threshold. The second 2 entries, ChargeStopControl and ChargeStopPercentage, change the stopping threshold.

The values of these entries are logical values and decimal percents, respectively. For example, to start charging your battery at 40% and stop charging at 80%, you should set ChargeStartControl and ChargeStopControl to 1, ChargeStartPercentage to 40 and ChargeStopPercentage to 80.

Don't forget to restart your computer to make the changes effective.

Be aware that this method does not seem to work for all users.

Not the answer you're looking for? Browse other questions tagged or ask your own question.