My question is similar to this question but the situation here is in an external keyboard (Logitech Comfort Keyboard K290). Is there anyway I can revert the Fn key to behave as it is pressed all the time?

note : this is not a problem, this is the default of the keyboard. all F keys cannot be pressed without Fn key as the default ones are shortcuts (brightness - volume - media - ..etc)

I am wiring the keyboard to Asus K55VD - Windows 8

up vote 3 down vote accepted

For anyone else that stumbles upon this question. SetPoint now includes a checkbox that enables you to change the default setting back to using F1-F12 instead of media keys:

enter image description here

For all the people still wondering how to do this on Linux, here is the link to the solution:

https://github.com/milgner/k290-fnkeyctl

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.