0

I've just bought a wireless printer Canon MG3560 and tried to connect it to my router TD-VG3631.

So far I tried 3 ways: a) press the wireless button until the light flash once using WPS connect to the router, b) press the wireless button until the light flash twice using PC connect to the router, c) using USB cable connect printer to router. They all failed and the driver installer cannot find the printer in the local network.

However, I found that in the wireless list from the router: enter image description here

I can find my printer here. But neither the DHCP list nor the ARP list shows the MAC address and the IP address. My guess is somehow the printer is connected to the router but there is no IP address assigned? I'm trying to figure this out without and not to return the printer.

Anyone can help me? Thank you!

0

Have you tried using the USB cable to connect the printer to your computer and then using the Canon drivers to configure the wireless settings. Once configured, the USB connection can be done away with.

  • Oh yeah I did. It showed a list of SSID that I can connect to, but even if I chose the right SSID and the right key, it wouldn't success. I've tried both the WPA and WPA2 types and it didn't work – user3928256 Jun 12 '15 at 11:05
  • Try changing the channel that your router is broadcasting on. Also ensure the router and printer have a common protocol in the list from b/g/n. If your router is on only g and printer is using n they cant talk. If nothing else works and your printer is under warranty try Cannon support. – Ali Jun 12 '15 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.