I just want to access the files on my Verizon LG G3 phone from my Linux PC.

I have adb installed and I followed this ArchLinux tutorial but adb devices outputs the following:

[grease-lightning]/home/lucas$ adb devices
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
List of devices attached 

I also followed this xda-developers tutorial but the MTP tool does not seem to detect my device properly.

I have usb debug on, and MTP mode on, (via Settings > Storage > usb/pc connection > "MTP" (default was PTP) on my Android phone).

I also tried running the commands mtp-detect with this output and mtp-connect with this output, but I cannot seem to access the file system. Most notably, it seems that the vender and product id are not detected, as quoted here from the mtp-detect output:

Device 0 (VID=1004 and PID=627f) is UNKNOWN.
Please report this VID/PID and the device model to the libmtp development team
   Found 1 device(s):
   1004:627f @ bus 3, dev 25

As instructed in the xda tutorial, here are the contents of my udev file:

[my-pc]/home/lucas$ cat /etc/udev/rules.d/51-android.rules

and here is the lsusb info for clarification:

[grease-lightning]/home/lucas$ lsusb | grep LG
Bus 003 Device 039: ID 1004:627f LG Electronics, Inc.

So, after trying these tutorials using the mtp and adb approaches, how can I connect to the files/media on my Android phone? Any suggestions?

I am using ArchLinux if that matters, and I would prefer a simple CLI approach to accessing the files on my phone.


I had the same problem with my nexus 5 on ubuntu. It was a problem of permissions; the device file was root for some reason.

What does this yield?

ls -l /dev/bus/usb/003/039

If it's owned by group root and owner root then an elegant solution would be to add the group entry plugdev in your udev, which you should already be a member of

| improve this answer | |
  • Thanks for the help, and this may be the problem, but Arch does not have a plugdev group. I tried creating a similar udev group with the contents SUBSYSTEM=="usb",ATTR{idVendor}=="1004",ATTR{Product}=="627f",TAG+='uaccess', but that didn't work either. Any suggestions would be helpful. – modulitos Jun 13 '15 at 1:29

I think I resolved this by using the jmtpfs tool. I ran the commands jmtp -l, which output this:

Device 0 (VID=1004 and PID=627f) is UNKNOWN.
Please report this VID/PID and the device model to the libmtp development team
Available devices (busLocation, devNum, productId, vendorId, product, vendor):
3, 48, 0x627f, 0x1004, UNKNOWN, UNKNOWN

Although it didn't recognize my device, I was still able to mount it with jmtpfs ~/temp/lucas-android then access the filesystem as usual.

BTW, I filed a request to add my device with libmtp on sourceforge

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.