1

Quick rundown, I have setup an AWS ec2 instance running Ubuntu 14.04. I have installed Ples & I have opened the necessary ports (both in the security groups & through the firewall) for Plex. I have verified that the required ports are open. Just for clarity on this question the command

`sudo iptables -L`

outputs

`ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:32400`

I can also telnet to that port successfully.

I have also attached this PMS to my myPlex account. My mobile device can see it as an available server.

My problem is that when I try to connect to this server either through my web browser, or my mobile device I immediately get a 401 Unauthorized error. If I set up an SSH tunnel like so

ssh -T -N -L 32400:localhost:32400 -i PlexTest.pem ubuntu@my.public.aws.ip I am able to access this web server via

http://localhost:32400/web

What would I have missed to be unable to access this server remotely?

Edit:

I did forget to mention in my post that I have also enabled remote access from the PMS itself.

https://dl.dropboxusercontent.com/u/22970579/Screenshot%202015-06-12%2013.01.57.png

2 Answers 2

4

My problem stemmed from the fact that I was hitting my.aws.pub.ip:32400

The correct URL to hit is my.aws.pub.ip:32400/web/index.html or my.aws.pub.ip:32400/web, unless you have setup some sort of reverse proxy to tell AWS to send all requests on that port to PMS.

Here is what I originally missed in the PMS documentation.

If you installed the Server on a device like a NAS, or the Server PC is somewhere else in the house, you'll need to know the Server's internal IP Address. Once you know that IP address, on a PC in your home:

In cases where you're installing Plex Media Server on a remote system, you'll need to first connect to it so that you can access it as if the system were local. Please see information in the Installation article for details.

https://support.plex.tv/hc/en-us/articles/200264746-Quick-Start-Step-by-Step

1
  • Why the downvote? Seriously, what was wrong about my answer? I always appreciate helpful feedback.
    – nbppp2
    Jun 19, 2015 at 15:22
3

You have missed the setting in Plex Media Server to allow access from devices outside your LAN.

Plex by default restricts access to the web interface by IP according to the local LAN interface(s).

You can access the settings under the "Server" tab of the Plex settings, and then looking under "Remote Access"

Plex Settings Screenshot

3
  • I had done this previously. I have edited my post to reflect that.
    – nbppp2
    Jun 12, 2015 at 17:16
  • 1
    So I don't know why it didn't work previously, but turning remote access off & then turning it back on seemed to do the trick.
    – nbppp2
    Jun 12, 2015 at 17:50
  • Possibly because your Amazon internal IP/subnet changed since the option was turned on?
    – qasdfdsaq
    Jun 12, 2015 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.