Recently I found that I could launch PuTTY but that no window was displayed. The Task bar has putty as a running application and I can right click on that to get the move and close option.

If I choose 'move', I get the outline of the PuTTY window to move but still no actual putty configuration window.

If I remote desktop to the same machine, I can launch PuTTY without any issues.

10 Answers 10

Right click putty.exe and on the compatibility tab check "Disable desktop composition." This worked for me. It disables Windows Aero theme while putty is running. It's annoying but works.

  • It was really irritating trying to move the window, but thanks your solution did the trick. – MTahir Jul 10 '15 at 18:29

The only true fix for this is to update to the latest version of PuTTY (>=0.65) from the main PuTTY website.

NOTE: 0.64 (current "stable" as of 2015-06-25) may not work, you need >=0.65. Check the prerelease or development builds.

The reason for this problem is in how PuTTY was incorrectly setting up and showing it's window, it worked more by accident than design and the "bug" that made it actually show up at all was fixed by a recent Windows Update. This meant the bug no longer worked and the PuTTy window no longer showed up properly.

From this PuTTY commit log

... a recent Vista update (all reports implicate KB3057839) has caused that not to work any more: on an updated Vista machine, in some desktop configurations, it seems that any attempt to fiddle with WM_SETREDRAW during dialog setup can leave the dialog box in a really unhelpful invisible state - the window is physically there (you can see its taskbar entry, and the mouse pointer changes as you move over where its edit boxes are), but 100% transparent.

So now we're doing something a bit more sensible. <snip> at the end of setup, we show the window in the sensible way, by a docs-approved call to ShowWindow().

This appears (on the one machine I've so far tested it on) to fix the Vista invisible-window issue, and also it should be more API-compliant and hence safer in future.

PuTTY window is there, although it gets the "transparent" property for some bogus reason. A lighter workaround than the ones I've seen so far is to set visibility back.

The following methods work on 32 bit Vista Home Premium, SP2. YMMV.

Method 1, a short AutoHotkey script:

; show_PuTTY.ahk
; Must be launched when putty.exe is already running

#NoEnv  ; Recommended for performance and compatibility with future AutoHotkey releases.
SendMode Input  ; Recommended for new scripts due to its superior speed and reliability.
SetWorkingDir %A_ScriptDir%  ; Ensures a consistent starting directory.

WinWait, PuTTY Configuration
WinSet, Transparent, 255

Method 2, Powershell script called from batch file (it doesn't need any additional programs):

# unhide.ps1

$definition = @"    
      [DllImport("user32.dll")]
      static extern IntPtr FindWindow(string lpClassName, string lpWindowName);

      [DllImport("user32.dll")]
      static extern int SetWindowLong(IntPtr hWnd, int nIndex, int dwNewLong);

      public static void ShowWin()
      {
         IntPtr hwnd = FindWindow("PuTTYConfigBox", "PuTTY Configuration");
         SetWindowLong(hwnd, -20, 524288);
      }
"@

add-type -MemberDefinition $definition -Namespace my -Name WinApi

do {}
until(Get-Process putty -ErrorAction SilentlyContinue | Select -p Responding)

[my.WinApi]::ShowWin()

Then you may call it from a batch file (eg. PuTTY.bat), placed in the same position where unhide.ps1 lies:

@echo off

rem PuTTY.bat

start "" "%ProgramFiles%\PuTTY\putty.exe"
rem Use %ProgramFiles(x86)% for 32 bit PuTTY on 64 bit Vista

powershell.exe -ex remotesigned -f unhide.ps1

Please see credits on comment below.

I tried a few things. i disabled the ati display device driver desktop management and grid management. this didn't make a difference. I quit the aquasnap pro windows grid manager. This didn't make any difference. With the desktop manager (Hydravision Multiple Desktops option) I noticed some odd things like I could launch putty on one desktop and then it would appear on a different desktop. For example, I'd launch it on desktop 1 and then it would be visible on desktop 2 but not desktop 1.

In the end, I disabled windows aero from Control Panel\Personalization. If you are using windows aero Window Color and Appearance will give you the option to "open classic appearance properties". Select that and then select windows vista basic as the colour scheme. Click apply and putty window is visible again. Hope this helps someone.

PuTTY version Pre-release 0.65 works in Vista with Aero. http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/vista-update-breaks-config.html describes what we (upstream) know so far about this issue.

  • Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Jun 17 '15 at 20:22

I also noticed this problem. In the choice of Putty executables from the Start menu I had Pageant. I started that, not really sure what it did.
It started a task in the task bar in the lower right. When I right click on it, it had a few chioces and one of them was saved sessions, one of which was one for my server. I clicked on that and it opened my normal ssh session. It appears on the lower task bar (from left) also, while the attempt at starting putty from the start menu still leaves a task that is PuTTY Configuration named. Closing the failed one does not interfere with the running session. Not too sure why this is but it seems to be a way around the problem.
I'm running Windows Vista with automatic updates. Putty is release 0.64.

6/17/15

I had same problem on Windows Vista. I just installed putty alternative kitty ( http://kitty.9bis.net/ ) and it worked fine.

The same problem I faced recently in windows Vista Ultimate. Changed the monitor colors as 16 bit and it worked for me. Try this.

Go to

Control Panel->Personalization-> Display Settings -> Monitor and set the colors value as ** Medium 16bit **.

Apply the settings and launch Putty. It started working for me. Found similar solution from Putty windows not displaying

I upgraded to the latest development snapshot of PuTTY from http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html and I am able to use PuTTY again in my Windows Vista 32 bit machine.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.