1

I want to make Russian my default keyboard input language, but OS X won't let me. Is there a hidden preference or something for this?

3
  • How do you mean, it won't let you? What happens when you try and change it?
    – slhck
    Jun 13, 2015 at 9:12
  • I gave it a try and it didn't work until selecting a Russian keyboard in the input menu in the menu bar (which is enabled by [] Show input menu in menubar in Keyboard Preferences. This on 10.9.5.
    – user187561
    Jun 14, 2015 at 6:44
  • Sorry, I must have been more clear. There is no option anywhere in the GUI to set the default input language. Every time my computer turns on, it's set to English. It is often reset back to English throughout the day, even though I have "Remember input language for each document" disabled.
    – Nikita
    Jun 14, 2015 at 8:11

2 Answers 2

1

In System preferences choose "keyboard"enter image description here

Be sure the "Show input in menu in menu bar" is checked then click the "+" sign in the bottom left keyboard preference pane choose your language and keyboard type for the language and click "Add" additional language pane then in your OS menu at the top right you will find and input menu where you can select "French" or whatever language you have chosen.enter image description here

EDIT

Adding default language to the os

  1. choose Language and Region in System Preferences
  2. Click "+" in bottom left corner of preferences pain.
  3. Choose your language
  4. you will be prompted asking if you would like to make it your primary language , do that.
  5. you may be prompted to add an input devices language
  6. click keyboard preferences. It will prompt you to restart, again , do that.

good luck

3
  • 1
    Thanks, but this is just switching languages. I need this French to become the default language when the computer turns on. Another issue is that the language gets reset back to English randomly when I'm using the computer.
    – Nikita
    Jun 16, 2015 at 4:18
  • That IS how you "make Russian my default keyboard input language" if you want to set your system language to Russian I can show you how to do that as well, however you will still need to use this method to set the keyboard language
    – mcgrailm
    Jun 16, 2015 at 12:43
  • 1
    Ok, what you've added after "Adding default language to the os" did help. Thanks a lot @mcgrailm! Not sure what was wrong with my preferences, but after I've removed and added Russian to "Languages" (as opposed to keyboard inputs), it seems to have started behaving as expected.
    – Nikita
    Jun 18, 2015 at 3:36
2

No, it doens't work like mcgrailm described at all. Actually + - are just to add and remove the language in a fixed sequence like MacOs wants. There is no way to set a default language. E.g. if I want to set German as default, always it comes behind chinese and British.

1
  • 1
    Please have a look on how to write a good answer. You aren't answering the question, this is a comment to mcgrailm's answer, which is not acceptable in an answer. You need to collect reputation through asking good questions and providing good answers before you're allowed to comment. I'd suggest you delete this before someone else has to. Answers like this will be deleted and a few bad quality answers like this will lead to an answer ban. Sep 27, 2021 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.