1

I'm trying to setup virtualization but am unable to use germany keyboard layout. The letters ö,ä,ü are not recognized when I try to setup the keyboard. The push of those buttons doesn't trigger a reaction in any way.

The host is running ubuntu 14.04 with following hardware specs:

Intel® Xeon® E5-1650 v2
Hexa-Core Ivy Bridge-E
incl. Hyper-Threading-Technologie
128 GB ECC RAM
2 x 240 GB SATA 6 Gb/s Data Center Series SSD

I'm trying to setup the keyboard layout here:

enter image description here

But there is no response and the time to wait is just running out.

I really don't have any clue on what could couse this weird behaviour. I've been trying to get it running with latest virtualbox and with vmWare Player, but both don't recognize the correct keyboard layout.

When trying to type within the server itself, everything works as expected.

I'm using xfce as desktop, though I would prefer a complete cli solution.

Is there any way to fix this?

migrated from serverfault.com Jun 14 '15 at 5:57

This question came from our site for system and network administrators.

0
+100

Normally,

   setxkbmap de 

does it from CLI. Otherwise:

    Settings -> Keyboard -> Application shortcuts -> Add -> Command: setxkbmap -layout de (adjust as required) -> OK -> <press the key combination you want>

Or again. alternatively,

     Applications Menu->Settings->Keyboard

And, last, you should install the very convenient xfce4-xkb-plugin package, and add it to your panel for quick changes.

I hope one of these four solves it for you.

EDIT:

@michael You don't happen to have a USB keyboard, do you?

Yes it is a USB keyboard

This is the root of your problem. USB support is only partial in VirtualBox without Guest additions (aka extension pack): you can use your keyboard, but you cannot change its layout. Install guest additions, then try again changing layout with one of the commands I gave you.

You may try things like: unplug keyboard, then start the VM, once it is up plug in the keyboard. Or use Devices-> USB to steal the keyboard, an so on.

  • Thank you very much, but still no luck. I can use the letters on the host, but not in the virtual machine. Can I do something there? – user389348 Jun 18 '15 at 17:27
  • @michael Just for completeness' sake: did you run those commands on the host or on the guest? They are meant for the guest. Also: guest? – MariusMatutiae Jun 18 '15 at 19:15
  • I tried on both, the host and the guest. On the host the first command line option you suggested ran without error but unfortunately didn't change the odd behavior. On the guest, I'get an error saying (translated) cannot start default display. In this case, the guest as well as the host both are ubuntu 14.04 server installations but I experience the same on ubuntu 15.04 w Gnome desktop as guest os. – user389348 Jun 18 '15 at 19:21
  • @michael I get the impression from the error message cannot start default display that you have a problem with Xorg. Try sudo loadkeys de, in the guest, pls. – MariusMatutiae Jun 18 '15 at 19:27
  • It says "Lade DE" (loading de) but doesn't change it as well. I have just noticed that I get an ö by pressing shift and . or ,. If this helps... – user389348 Jun 18 '15 at 19:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy