I have a local server Wildfly and I have a test application which I can access:

http://localhost:8080 works.

Now, I have comcast Xfinity with a modem (no additional router). I am working on CentOS 7. It looks like my internal IP address assigned by the modem is following:

[abigail@localhost ~]$ hostname -I 2601:9:500:ae7:4637:e6ff:fe40:74f2 I tried to access, but I can't. The website is not accessible. To do this, do I need to configure port forwarding in the modem? I did that but it still doesn't work. In the modem, I added one entry in the 'port forwarding' panel.

Port8080 TCP/UDP 8080 8080 Where I am doing wrong?

Edited for more info.

abigail@localhost ~]$ traceroute comcast.com
traceroute to comcast.com (, 30 hops max, 60 byte packets
 1 (  0.700 ms  1.488 ms  1.769 ms
 2 (  19.791 ms  20.272 ms  20.395 ms

More info from the modem's configuration page:

WAN IP Address(IPv4):
WAN Default Gateway Address(IPv4):
  • "Modem (no additional router)" presumably means you don't have a router integrated into the modem either, right? (Comcast has been pushing those.) Because does not look like a Comcast public IP address. traceroute comcast.com or such should give you a hint how the network topology looks like. Jun 14, 2015 at 6:35
  • The modem's public IP is, which can be seen from "whatismyipaddress.com". is the dynamic IP assigned to one of my computers I am working on. My goal is to make my local server can be accessed on the internet through But I think the first step is to make my home website can be accessed by the internal IP, not or localhost.
    – martin
    Jun 14, 2015 at 6:50
  • No, I think modem includes router, so the configuration is supposed to be easier.
    – martin
    Jun 14, 2015 at 6:50

1 Answer 1


If a network service is reachable via only, it is most likely configured to accept connections only on To change this configuration, please refer to the server’s documentation. I’m not familiar with Wildfly, but it looks like you want something like this:

<interface name="public">

Since you’re trying to connect via your local network, the modem isn’t involved at all. Unless you want to expose your service to the internet, you should remove the port forwarding you configured.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.