I just configured my Raspberry Pi with Raspbian. I want to SSH into it with my laptop, so I connected my laptop and the pi with an Ethernet cable. Then, I went to the raspberry pi command line to get the IP address using ifconfig. There was no IP address (similar to the problem here). So, I tried the solution offered on that post and ran:

sudo ip addr add 192.168.x.x/24 dev eth0

I ran ifconfig again and saw the IP was set, so I went to my laptop and tried to ping the IP address I set for the pi. The following happened:

Pinging (Pi IP address) with 32 bytes of data:
Reply from (Computer IP address) Destination host unreachable.
Ping Statistics for (Pi Ip Address): 
Packets: Sent = 4, Received = 4, Lost = 0 (0% Loss).

I tried Putty to see if I could get the SSH to work (even though ping didn't...I thought it might be worth trying), and I get this error:

Network Error: Connection Timed Out 

Is there something I am doing wrong to SSH into the Pi? Or could this be a hardware problem like explained here?

I found other ways to set static IPs, but from my understanding, you have to have a working dhcp address. I don't have that.

  • Is your laptop on same 192.168.x.x/24 network as the RPi?
    – raspi
    Jun 14 '15 at 18:45
  • Yes, my laptop is 192.168.y.a and the pi is 192.168.y.b Jun 14 '15 at 18:50
  • Are you just connecting the two directly with a cable? Jun 14 '15 at 20:24
  • @Jeremy French yes...the laptop and the pi are connected with an Ethernet cable Jun 14 '15 at 22:31
  • @JustBlossom A crossover ethernet cable, I hope? or a normal one?
    – Jarmund
    Jun 14 '15 at 23:11

Try to connect your rpi directly to your AP/router and turn your rpi on. The router should give you an IP automatically. Then from your laptop you could enter to your router GUI and search for the DHCP list where you will find your rpi IP address.

If you don't have any router available you should configure your laptop to work as a DHCP server. There is many tutorials such this one.

Finally, it might sound very basic but you could try it with another Ethernet cable if you have one available

Hope it helps


SSH daemon is disabled in Raspbian by default. You need to use raspi-config to enable it first.

As for the IP, as far as I remember, Raspbian comes with avahi-daemon preinstalled, so you should be able to use your_pi's_hostname.local domain name to access it from your laptop, provided said laptop has avahi/Bonjour installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.