4

I've been running VMWare Workstation 11, with 32 & 64-bit guests just fine but I haven't run in in a few months. I tried starting it up again and I get:

Blockquote Binary translation is incompatible with long mode on this platform. Long mode will be disabled in this virtual environment and applications requiring long mode will not function properly as a result. See vmware.com/info?id=152

What I get out of that page is that VT-x needs to be enabled, however, it is already enabled in the BIOS.

I get the error message trying to run either 32-bit or 64-bit clients, all of which ran just fine a few months ago. After clicking okay to it for a 32-bit VM, it will run. A 64-bit client won't, telling me:

Blockquote The virtual machine is configured for 64-bit guest operating systems. However, 64-bit operation is not possible. This host supports Intel VT-x but Intel VT-x is disabled.

The first suggestion is to enable Intel VT-x and to disable 'trusted execution'. VT-x is enabled in the BIOS and while the i7-2600 supports VT-d, the 2600K does not.

I'm running Windows 7 Ultimate x64 on an ASUS P8Z77-V Deluxe with an i7-2600K, and the UEFI BIOS. "Intel Virtualization Technology" is Enabled in the BIOS. However when I run System Information for Windows (SIW) or PC-Wizzard, they tell me it's disabled. I know where the setting is under Advanced\CPU Configuration and it shows Enabled.

I'm very puzzled at to what's going on. The BIOS is the same one (1805) that I've been running just fine with the last couple years so I'd rather not mess with an update to the latest version. Also before I got Workstation, I ran VirtualBox just fine. It's been uninstalled, and I've been running Workstation 11 fine until just recently.

As far as I know, I'm not running anything else that's doing virtualization, and the Windows Features does not show Hyper-V.

I'm at a loss here to understand why VT-x shows as disabled under Windows 7 when it's clearly enabled in the BIOS, or what could have caused it to be disabled.

  • 1
    I have seen in the past an OEM UEFI firmware where the setting for this feature was bugged, the option when enabled actually disabled the feature, try disabling it in order to enable it. – Ramhound Jun 15 '15 at 10:56
  • Great idea. I tried that but it's still disabled. I did notice that sometimes when I went into the BIOS VT-x seemed to have turned itself off which I thought was odd. No joy, but thanks for the suggestion. – SDMark Jun 15 '15 at 11:26
  • 1
    Verify your running the current firmware version, if it turned itself off, then it was diabled. – Ramhound Jun 15 '15 at 11:34
  • Thanks. When I noticed it was off, I turned it back on. That's only happened a couple times in the last year and it hasn't been turned off when I've checked after having the problem.The firmware isn't the latest and greatest but it's been working okay for the last two years with no virtualization issues, so I'm reluctant to mess with what has been working okay up until now. I'm guessing that somehow, it's something I've installed. I just have no idea what it could be since it seems like it would be something at kernel mode level. – SDMark Jun 16 '15 at 7:20
  • 1
    Make sure you don't have any other virtualization products or features enabled. – David Schwartz Dec 31 '15 at 8:25
1

Hope my answer helps someone who ends up on this page for the question

I had just updated my BIOS and found that emulator on Android Studio was not starting mentioning "VT-x not enabled". When I checked task manager it showed Virtualization is Disabled

On entering BIOS found that Virtualization showed enabled. I exited and googled up in vain.

How I got rid of it: I entered BIOS setup once again, this time I disabled it and re enabled. Saved and exited. When I again checked in Task Manager, "Virtualization showed as enabled"

I made sure emulator is also running as I am typing this answer

0

i tried to install Avast antivirus (no promoting purpose), go to setting > troubleshooting > check the hardware-assisted virtualization, then restart the PC/laptop make sure you've enabled it from BIOS too

works for me

here is a screenshoot

-1

Try unchecking Avast "Enable hardware-assisted virtualization", which did work for me, on my VAIO Z.

  • 1
    Welcome to Super User. External links can break or be unavailable, in which case your answer would not be useful. Please include the essential information within your answer and use the link for attribution and further reading. Thanks. – fixer1234 Dec 31 '15 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.