I am running Windows 7 X64 Pro and I had a extra 650Gig Hard Drive laying around that I thought would be a good candidate for turning it into a drive for keeping system restore and page file. Now the problem I am having is it is still showing up as a drive, i.e. E:. Is there a way to assign the page file to a drive without a drive letter? In the past I have tried to use a entire partition for a swap and keep getting a message saying that "Drive X is almost out of room". Am I going about this the wrong way? Is there a better way of doing this? I am running some pretty resource hungry programs CAD inpaticular and have already maxed out my RAM so I am trying to get every ounce of performance I can.

  • System restore cannot be moved because of how filesystem snapshots work.
    – Daniel B
    Jun 15, 2015 at 16:18

1 Answer 1


Try this trick of mounting it with an NTFS path: http://www.nerdscene.com/2010/03/31/143/

The details are a bit more in depth than will fit well in an answer here, but the general idea is to mount your swap partition as a path on your main drive, then remove the drive letter mapping.

After that, you need to twiddle with HKLM\System\CurrentControlSet\Control\Session Manager\Memory Management\PagingFiles by setting it to the path and min/max sizes of the file in MB (eg C:\Windows\Pagefile\pagefile.sys 10240 10240). By making the sizes identical, you prevent resize thrashing as you're going to dedicate this drive to swap use anyway.

  • 1
    Can we please provide all relevant information in the answer? Link only answers are really not acceptable.
    – Ramhound
    Jun 15, 2015 at 15:58
  • Ok, fine ;) Added at least overview level instructions.
    – BowlesCR
    Jun 15, 2015 at 16:15
  • In my opionion the blog post is even less helpful, the article doesn't even, fully explain the process. If it does then its so poorly outlined that its nearly impossible to grasp easily.
    – Ramhound
    Jun 15, 2015 at 16:42
  • Yes this worked beautifully! Now the only thing that I couldn't figure out maybe I just missed it, quite the lengthy article but how to you remove that darn drive letter mapping? I have my drive showing up as E: kinda annoying Jul 1, 2015 at 0:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.