4

I'm trying to export my XLSX file to CSV using Excel 2013.
The problem I am facing is that the resulting CSV file uses semicolon (;) as a separator. I need it to be a comma (,).
I've changed my regional settings to use comma as a list separator:

enter image description here

However, Excel still exports with semicolon. How to make it export csv with comma as a separator?

4
  • Try changing the Decimal symbol from , to . as well.
    – DavidPostill
    Jun 15, 2015 at 16:50
  • ... and then the thousands grouping from . to " " (space). Yes, it is as horrible as this - I'm not sure this helps though. It might be easier to load the file into wordpad or notepad and replace ; to , .
    – Hannu
    Jun 15, 2015 at 19:45
  • there's always an option to do post-processing.. but being that I'm often in the need to export csv, it would be useful to know how to do this in Excel directly
    – srgb
    Jun 16, 2015 at 11:33
  • superuser.com/questions/606272/…
    – Sam B
    Jul 21, 2018 at 11:59

1 Answer 1

3

As you've spotted, the list separator isn't for CSV.

I guess this is because you are using comma as the decimal so the default for "comma" separated files becomes semi-colon separated.

I think the only native solution is to change back to standard english settings before saving the file.

Or, as mentioned above, use a utility to change the ; to , post save. You could even get clever and intercept the save process in VBA (or simply create your own save button) to output the csv and then call out to the filing system libraries to do a replace text on the file.

1
  • I confirm this works. @srgb you should mark this as the correct answer.
    – Redoman
    Nov 12, 2016 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.