8

I own a Dell Inspiron N5050 Notebook running Windows 7 Home Premium. I am trying to permanently disable the touchpad. I installed the appropriate driver in order to manage my touchpad preferences, and successfully disabled it - but once the machine was rebooted, the touchpad was on again. I really don't care if I will need to keep disabling it each time I boot up, but does anyone know of a way to permanently disable it?

3
  • 2
    Many laptops can disable touchpad with Fn+something. Mine (an Acer) uses Fn+F7, I have seen Dell ones using Fn+F3. This is not permanent but easier to disable after each reboot. A simple script to run at startup would be better (and is the solution I use on Ubuntu).
    – laurent
    Jun 16, 2015 at 0:52
  • 3
    Consider using a hammer or screw driver. Jun 16, 2015 at 1:01
  • This question is a duplicated of superuser.com/questions/927973/… Jun 16, 2015 at 8:29

5 Answers 5

14

Approach 1: BIOS

The touchpad can usually be disabled in BIOS. On my Dell Latitude E6430s, the option is POST Behavior, Mouse/Touchpad. There is even an option to disable the touchpad only if an external mouse is attached.

Approach 2: Device Manager

Open Control Panel, System, Device Manager. Navigate to the mouse, right click on it and click Disable.

Approach 3: Physically unplug

According to a disassembly video, it appears that you can unplug the touchpad by removing the keyboard (at 3:45) and removing the small ribbon cable near the touchpad.

https://www.youtube.com/watch?v=NR0iRYLEO9s

4
  • 2
    +1 upvote. My opinion of the options are as follows; #1 isn't a universal option. #2 is a universal option and is what I would try first. (reboot may be required) #3 is just as effective and absolutely a solution however it's pretty extreme and entirely depends on OP's preference for not using the touchpad. Personally, I would try to script the disabling process and run it at startup using Task Scheduler before I went that far. Although, that may not be as easy/possible depending on the enduser
    – user431052
    Jun 15, 2015 at 23:38
  • 2
    I agree with BiTernary. Using Device Manager (#2) to disable it is universal and is easy enough to undo if you need to.
    – cyberbit
    Jun 16, 2015 at 1:11
  • Also, notice that opening a laptop and taking off the keyboard will void your warranty. Jun 16, 2015 at 8:22
  • @IsmaelMiguel: not necessarily true, depends on the manufacturer (which in turn depends on how the machine is designed, if the keyboard is user-serviceable by design it's probably not true). I am almost positive you could tamper with the keyboard of IBM-era Thinkpads and Big Blue wouldn't get particularly upset. Jun 16, 2015 at 14:34
7

(Win)+X opens the "Windows Mobility Center".  On my Dell Inspiron (running Windows 7), it looks like this:

Windows Mobility Center

I disabled my touchpad there, and it has stayed disabled through many reboots.

2
  • This would also work. Doing that is equivalent to disabling the device in Device Manager. If it's not OEM Windows though, those options might be missing.
    – cyberbit
    Jun 16, 2015 at 2:44
  • The keyboard shortcut opens a right-click menu over the start button in Windows 8 and later. However, this menu still contains the "Mobility Center" entry, just for future reference.
    – SimonT
    Jun 16, 2015 at 15:30
2

You don't really have to disable the entire touch pad, you just have to turn off the tap to select feature. Go to Control Panel>Mouse and select the touch pad tab. Find the tap-to-select tab, uncheck the enable box, and click OK. Then, just touching the pad will have no effect, but it will still respond to a moving finger. And the change is permanent.

1

For a simple, ugly, non-technical option, you could just cover the touchpad with tape.

1
  • 9
    Seriously, you would probably need to tape a piece of cardboard over it.  Mine is so sensitive, I can practically register a touch just by breathing on it.  I'm sure it would be able to detect contact through most forms of tape. Jun 16, 2015 at 1:55
1

You asked just the right guy! I have an N5050 with an MS3500 USB mouse. To avoid physical alterations install both MS mouse and keyboard center 2.3.180.0 and Dell Touchpad driver by Alps electric 7.1107.115.102. Go to control panel click mouse and look for a touchpad tab. If not there something is missing. Click touchpad and go to buttons. Disable both buttons and touchpad. Click disable when USB mouse is present.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.