1

I tried to transfer some media files to my android device, but I got the error:

USB not recognized error.

I tried removing the power supply, disabling Windows Firewall and restarting but nothing worked. I connected another android phone, and surprisingly enough, it connected fine. So, that means the MTP protocol on my Windows machine works fine, and the problem exists in my android device itself. It says:

Unable to find software on your PC that can recognize your device.

What can I do ? Note that both android devices are of version 4.1.2

4
  • Have you installed the device driver on the system? – Kunal Jun 16 '15 at 11:00
  • My android device was working a few days ago, so I suspect that's not the issue. – Amr Ayman Jun 16 '15 at 11:04
  • The error says it, As much as i do not like that mass storage is no longer used, my phone has specific driver thing it tries to stick on my computer, and another device comes in as a different device. Fire up your Device manager, show hidden and disconnected devices, cleanup the mess that is there always :-) and track how that device shows, and what driver it think it needs. It is probably just a matter of cleaup and uninstall the old junk so it even can try the automated addition again. It might include uninstalling from the "Programs and Features" (add/remove) in control pannel too. – Psycogeek Jun 16 '15 at 12:55
  • Nope, this does not work at all with the latest version of Windows 10 Pro – Kevin Russell Jun 7 '19 at 14:27
1

My LG android phone would not connect to Windows 10.

This worked for me:

  1. Goto Settings → About Phone → Software Info
  2. Tap Build Number 7 times -- This makes you a Developer and turns on Developer Options

  3. Goto Settings → Developer Options

  4. Check USB debugging
  5. Select USB Configuration, it was set to Charging only
  6. I changed the setting to MTP (Media Transfer Protocol)
1
  • This is accessible from the notification drop-down. Swipe all the way down on the Notification drop-down, tap the notification for the USB connection (i.e. Android System - Charging this device via USB), then select File Transfer. You do not want to change this via the Developer Settings, as that changes the default protocol and it's a massive security risk to have the default behavior set for filesystem access, which is why it's defaulted to Charge Only. – JW0914 Jul 27 '19 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.