5

I have to compile a program (not made by myself) and in his autogen.sh there is a script command that search libtool

LIBTOOL=$(which libtool)

but the command don't find the command. I see the path for libtool is /usr/share/libtool instead /usr/bin/libtool.

I locate libtoolize in /usr/bin/, but I did not change any path.

I'd like to know if there is difference between libtool and libtoolize.

1

They're not the same thing, libtoolize is part of libtool.

From this link (http://www.gnu.org/software/libtool/manual/html_node/Invoking-libtoolize.html):

The libtoolize program provides a standard way to add libtool support to your package. In the future, it may implement better usage checking, or other features to make libtool even easier to use.

  • I solved changed LIBTOOL=$(which libtool) with LIBTOOL=$(which libtoolize). Yes I've read the articles, but the question is: now this is the standard? – Kyrol Jun 17 '15 at 15:37
  • If it is the standard of using libtool then the documentation is in need of an update. I tend to think it's more likely to be a matter of how the program you're working on is attempting to use libtool (maybe outdated - from an earlier libtool version maybe?). – Dan Cornilescu Jun 17 '15 at 16:02
21

I ran into this same problem today on a Debian system and (eventually) discovered that though the libtool package was installed, the libtool-bin package was not.

apt-get install libtool-bin

Problem solved: which libtool prints /usr/bin/libtool.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.