14

Since upgrading to OS X Yosemite I have been experiencing this sporadic issue where I suddenly lose the ability to scroll up/down in terminal using my trackpad. Scrolling on the trackpad will instead cycle through all of my previous commands.

I've read about this behavior with vi in Yosemite, but I've not been able to use any of the fixes that they have mentioned (e.g. holding Shift and then scrolling).

Is there a way to get around this or switch between different modes? It is incredibly irritating when it happens.

23

This issue is not specifix to OS X Yosemite or OS X in general, this happens to all the terminals when a certain control sequence is issued.

It is very likely that this will go away after you run

$ reset

Here is an excerpt from man tset:

When invoked as reset, tset sets cooked and echo modes, turns off cbreak and raw modes, turns on newline translation and resets any unset special characters to their default values before doing the terminal initialization described above. This is useful after a program dies leaving a terminal in an abnormal state. Note, you may have to type

       <LF>reset<LF>

(the line-feed character is normally control-J) to get the terminal to work, as carriage-return may no longer work in the abnormal state. Also, the terminal will often not echo the command.

| improve this answer | |
5

This happens to me every time I am using vim via ssh and the connections is closed abnormally (timeouts, server shutdowns...). If this is the case, then it is sufficient to run vim and close it, to get the original scroll settings back.

| improve this answer | |
2

It seems like you're using screen. Without it, I don't believe there is any setting that will allow to scroll through previous commands. In your case, turning off Scroll alternate screen will disable sending scroll events to the Terminal.

"When the alternate screen is displayed, send input instead of scrolling the terminal view. Press Shift to temporarily reverse this setting."

enter image description here

| improve this answer | |
0

Something that might work is using PageUp / PageDown keys on your keyboard.
Depending on the keyboard you have, you might not have dedicated keys & you'll need to use the Fn + Up/Down Arrows to do it.

This may be of some help, the OP is trying to stop the scrolling that I think you are looking to get back, so it might just be a case of enabling the option shown: https://discussions.apple.com/thread/6699311?start=0&tstart=0

There's some information about magic mouse scrolling here: http://macmint.com/how-to-disable-magic-mouse-scrolling/ which may also be what you are looking for.

HTH

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.