12

I was editing a document in Office Word 2007 on Windows XP and suddenly all sorts of words are underlined as misspelled. I go into Word options and it talks about French dictionary! In the preferences, my primary language is set to English (US) and that is only language set.

What is going on??? How can I get back to English spell check?

3
  • I fixed the problem by rebooting windows and deleting one sentence from the document that was still thought to be in French and retyping it again.
    – WilliamKF
    Jan 8, 2010 at 15:38
  • 1
    I couldn't understand your question. It appears on my computer entirely in French. :-)
    – fixer1234
    Oct 12, 2014 at 18:08
  • In case you are using Mac office 2011, you can change it under the tools tab> language
    – CyberMan
    Jan 29, 2015 at 13:16

5 Answers 5

21

To fix issue like this in Microsoft Word where the Synonyms for a particular document is in different language or the proofing language/spell check is changed to French, Spanish, etc; First select all the document (shortcut Ctrl + A) and navigate to Review Tab > Language > Set Proofing Language and then in the pop up , make sure the check-box "Detect language automatically" is unchecked.

Also ensure that your desired language is set as default (Select the language and click the button "Set as Default")

enter image description here

1
  • 1
    What is the cause of this problem, so that if it is 'cockpit error' we can avoid doing it again?
    – Doug Null
    Sep 4, 2017 at 21:18
1

In case of Word 2007, go to Review tab, then to Set language, and then to the language of your choice (English). I think that should fix it.

2
  • Language was set to English (US).
    – WilliamKF
    Jan 8, 2010 at 15:37
  • In Word for Mac 2011 (Version 14.5.2) you select all and choose Tools ( from the menubar) > Language... Aug 10, 2015 at 19:07
1

There are two things at work here probably:

  1. Word tries detecting the language as you type. This works fairly well when you got like 5 to ten words minimum and eventually provides you with correct spell-checking even in multi-lingual documents.

  2. Word switches the language based on the input language. I have Polish installed as input language, along with the proper keyboard layout and when I switch to that in Word I get spell-checking in the correct language.

The easiest immediate fix is probably to select all, then click the language in the status bar and select English.

It might be that your default style is set to French (for whichever reason; that usually doesn't happen automatically); you may want to set the language there too.

1
  • I suspect that it is item 1 above and that word thought a subset of the document was in French due to some glitch. Reboot and delete of that section fixed the issue.
    – WilliamKF
    Jan 8, 2010 at 15:39
0

I encountered in PPT 2007 where I was typing text in and suddenly normal words, such as "your" and "windows", were being highlighted as being incorrect. I right-clicked on the misspelled words and the spelling showed what I beleive was French spelling. I looked at the main dictionary and English was selected.

As mentioned above, I also went into the REVIEW>LANGUAGE, scrolled through the list and selected English (US), even though it was already highlighted, and then clicked default. The wording that was marked as incorrect was now correct. I can only guess that I had accidently hit a key combination while typing that forced a different dictionary.

0

This is a weird bug in Word, which still exists in Word 365 (just encountered it in October 2022!). I tried various solutions mentioned above, and none worked. In the end when I went into this option I finally got it to be showing French, and reverted to English - I wonder if I had the dodgy line selected at the time?

enter image description here

Even if you show print characters, there is no symbol inserted in your document to say you suddenly want to switch to French proofing. I wonder if an image added contains a series of characters which triggers this instruction? Weird.

Not the answer you're looking for? Browse other questions tagged or ask your own question.