0

So far I've tried my google fu to figure out exactly what I've done on the terminal (I'm running OS X Yosemite 10.10.3), but I'm not satisfied with my current understanding on how mounting and mount points work on a Macintosh machine... this is pretty much what happened:

I tried to manually install rEFInd per the instructions found here (http://www.rodsbooks.com/refind/installing.html#osx), and so far have done the following on my terminal:

:~ felix$ mkdir /Volumes/esp

:~ felix$ sudo mount -t msdos /dev/disk0s1/Volumes/esp

:~ felix$ sudo mkdir -p /Volumes/esp/efi/refind

My current understanding is that I made a "mount point" inside my local user directory (User "Felix") mounted an msdos type filesystem onto the EFI, and then made a nested directory within the esp folder that I made on the first command. However, I can't find these directories in the felix directory. What did I do? What exactly did I mount, and where did I mount it? Why can't I find /Volumes/esp?

If I want to start over again and reverse all the changes I've made with these three commands, what should I do?

0

You missed a space. The middle command is actually:

sudo mount -t msdos /dev/disk0s1 /Volumes/esp

This command means "mount the /dev/disk0s1 partition to the directory /Volumes/esp directory (which you created in the previous step), and force it to be an msdos filesystem type"

Since you never accomplished this step, my guess is that the '/dev/disk0s1' partition is not yet mounted.

To undo EVERYTHING:

sudo umount /dev/disk0s1/Volumes/esp (no space, and I expect this to fail)
sudo rm -r /Volumes/esp

At that point you should be back at the beginning.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.