0

I am connecting to both a wired and wireless networks. The wired network should be used for a virtual machine and the wireless for internet on the host.

In order to set this up, I changed the order of the Connections in the Advanced Settings: enter image description here

The issue is that the settings are ignored and the Ethernet is used on the host as well. When I try to access an internet site, the Ethernet connection is used an this causes errors. If I unplug the Ethernet, I can surf the web again but the Virtual machine can not access its resources.

3

1 Answer 1

2

These 'Advanced Settings' just doesn't do what you want, they just change network adapter order when some software lists adapters but they don't change connection priority as you need.

You need instead to check each of your network connection properties, then check TCP/IP properties -> Advanced, then disable Automatic metric checkbox and set Interface metric to a number, the interface with lowest metric value has priority.

1
  • thank you for your answer. unfortunately I can not check that as I do not use a windows laptop anymore. If someone can confirm that this does indeed work, I'll check the correct answer box
    – Micha Roon
    Mar 31, 2017 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.