0

While programming using QtCreator, I got used to its camelcase-aware completion, e.g. typing MC<ctrl-space> would offer MyClass as a completion option.

Now I am basically annoyed about that because I sometimes type MD<tab> in bash and expect it to offer MyDirectory as a completion option, if that directory exists. Can bash be configured to actually do that?

Note that this question is basically the same as this one, but about bash instead of zsh: How can zsh be configured to autocomplete directory name with camelcase matching?

0

Put the following in your .inputrc

set completion-ignore-case On

That should turn on case-insensitive autocompletion... which will then work for camelcased files.

| improve this answer | |
  • Ah... I see now that you only want to type the uppercase letters... that won't work with this setting, but you should still be able to match files/dirs with the first letters correct in a case-insensitive way. – Sig-IO Jun 18 '15 at 22:11
  • Right, I would only want to type ED for the completion to ExampleDirectory, with your answer I would have to type e.g. ex<tab>. – anderas Jun 19 '15 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.