4

I'd just like to turn it off, because it's quite distracting when every PDF looks so colourful. I've looked through chrome://flags and there's an LCD text anti-aliasing option but it doesn't seem to affect the PDF viewer.

Here's how chrome Version 43.0.2357.125 (64-bit) on Fedora 21 renders this PDF for me: enter image description here

A little closer:

enter image description here

Quite different to an old version of adobe reader with only slight colouring:

enter image description here

And evince with no sub-pixel antialiasing:

enter image description here

This is what my monitor looks like up close:

enter image description here

From: http://www.lagom.nl/lcd-test/subpixel.php

enter image description here

enter image description here

Which looks much better than chrome's PDF viewer.

Update: Still an issue in Fedora 23, chrome 48.0.2564.103.

3

You can fix your font rendering issues in the PDF viewer by installing freetype-world, since you're on Fedora (according to this bug report: https://bugs.chromium.org/p/chromium/issues/detail?id=479400).

I'm still trying to figure out how to disable subpixel rendering in the PDF viewer on CentOS (which doesn't have a freetype-world package). So far I've tried editing ~/.fonts.conf and ~/.Xresources, and changing the Gnome system settings (based on the instructions here: https://bugs.chromium.org/p/chromium/issues/detail?id=408079#c4).

| improve this answer | |
  • 1
    fantastic. sudo dnf install freetype-freeworld. problem gone. thanks very much for taking the time to post the answer! If only it was so easy for your distro. – jozxyqk Mar 3 '16 at 6:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.