I've scoured the web for several days now, essentially every single time I encounter this. I hope someone here knows a solution to this.


  • I'm using the latest stable release of Firefox at the time of writing.
  • I'm running on Dual Stack (native IPv4 and native IPv6).
  • Any tab exhibits the symptom as soon as you refresh or open a new URL.
  • No other browser or client is affected. I can use Opera, Internet Explorer, PuTTY etc without any such symptoms while Firefox continues to show me "Server not found".
  • NB: The DNS cache service on my box is turned off (meaning ipconfig /flushdns is out of the picture).

This remains unsolved as of July 2016. I still experience the DNS "outages" which seem to affect only Firefox.


I recently switched to Firefox and I am experiencing "Server not found" errors in intervals from less than an hour to several days.

enter image description here

This happens out of the blue, except that when I disconnect Cisco AnyConnect, this seems to be a sure-shot way of exposing this behavior. The issue, however, also occurs sporadically without any VPN software even running.

Stuff I researched and tried

I tried F5 obviously, but that never worked. The only thing that works reliably is to restart Firefox. Personally, that would mean I would have to switch browser again, as this behavior is simply unacceptable.

I found this several year old thread which suggests turning off IPv6, which is also recommended over at mozillaZine. In fact this prompted me several days ago to turn both IPv6 and DNS prefetching off by setting the following options in about:config:


Yet I have seen the symptoms again in the days since the configuration change (I have since reset those two options).

Now what I found flabbergasting was that when I looked at the outgoing requests from my machine using Wireshark while attempting to refresh the tabs that showed those symptoms, I saw not a single DNS request: zero, nada. What I saw instead were NBNS requests, i.e. "NetBIOS Name Service". And in fact the requests contained the very names of domains I was trying to access from Firefox.

Please note that after restarting Firefox, I can see these NBNS requests also for cases were a standard DNS lookup fails (not the "connection", but the lookup fails, I can see DNS responses). That is wpad for example fails to resolve via DNS in the intranet and then internet and then ends up as an attempt via NBNS.


How can I either prevent this from happening in the first place or when it happens recover from it without having to restart Firefox? This being: Firefox losing its ability to resolve server names via DNS.

  • 1
    Have you tried to play with the network.dnsCacheExpiration option? Set it to 0 to disable internal Firefox cache. – VL-80 Jun 19 '15 at 17:22
  • Also, when problem occurs next time, instead of restarting Firefox try to Clear Recent History with only Cache being checked. – VL-80 Jun 19 '15 at 17:29
  • @Nikolay: I have not. Will set it to 0 now. I'd like to avoid clear recent history if I can, but I'll give it a spin at least, so see whether it can help resolve the issue. Thanks for the feedback. – 0xC0000022L Jun 19 '15 at 18:23
  • Also, take a look at this question at StackOverflow. It is about Firefox DNS cache. – VL-80 Jun 21 '15 at 13:29
  • I have been experiencing the issue again, so network.dnsCacheExpiration=0 didn't help. – 0xC0000022L Jul 13 '15 at 8:46

A couple of months ago I had exactly the same problem with Firefox. Same symptoms, only Firefox stopped to resolve addresses... opera, chrome, ie, etc. all worked like a charm, I restarted Firefox and all working fine but just a few minutes. As far as I know, the only difference with you is that I was using Firefox Portable from portableapps.com. I reinstalled it a lot of times and tried all that you can imagine but I get nothing so I switched to Portable version of Firefox ESR (Extended Support Release) and with this version I had zero issues but it is an old version (31.7).

Well, two weeks ago I decided to try it again with last Firefox Portable version 38.0.5 and the same problem... but this time I found a Firefox profile in %APPDATA%\Mozilla\Firefox\Profiles so I removed it (Firefox should be stopped) and that's all, for some reason I can't explain, that profile was causing the DNS issues, since then, zero issues with last Firefox Portable version.

It is something you could try to check, maybe you have some corrupt profile that is causing some conflict, you could try to delete the profiles and Firefox will create a new one in the next start, but please, before delete anything, backup backup backup ;).

Sorry, I know this is not an answer but I can't add a comment.

  • How is this not an answer? Sure there's a lot of fluff, but deleting profiles sounds like a good solution (for the reasons you gave). If you remove the fluff, this would be a better answer. – Cfinley Jun 19 '15 at 20:04
  • 2
    @Cfinley: it is an answer (which is why I upvoted it), but how is removing the profile ever a good idea? For starters it means that I need to start over, losing everything in my profile (using backup/restore might obviously reintroduce the "corruption"). It also means that something that might be a bug in Firefox goes unfixed, because we dodge the question: what is the ultimate cause? Where do you see the causal connection between profile and experienced failures? If a restart with the exact same profile works, how can it primarily be "the profile's fault"? – 0xC0000022L Jun 20 '15 at 15:41

I found it was only the cert8.db file that required deleting from the profile folder to resolve the issue for me which is a lot less drastic than deleting your entire profile.
I would notice that a specific site with a self signed certificate would take longer and longer to load over a period of days and weeks until eventually I'd get nothing except the "Server not found" message. Now my solution is

Close Firefox
Navigate to %APPDATA%\Mozilla\Firefox\Profiles
Delete cert8.db file
Restart Firefox

  • But you write that a restart is still required. But that's exactly what I want to avoid. Right now I can get it to work again by restarting FF and then it works for a few hours or days. But the restart is what is unnecessary. Thanks anyway for sharing your findings. – 0xC0000022L Sep 1 '15 at 10:53
  • I think the restart refers to starting firefox again after deleting the file... – chmac May 21 '16 at 12:45

I have exactly the same problem. (I'm using a Dicrect Access VPN). Though I have no solution for the issue, I have a step forward in investigation: As suggested in a comment above I took a look on about:networking When attempting to access a intranet host I've got 2 different entries in DNS tab: intranet_host ipv4 172.x.x.x 110 intranet_host ipv4 fdcb:xxxx:xxxx::acxx:xxxx 109

Randomly, accessing the intranet_host will fail. Accessing instead intranet_host.my_domain.com always work. Again 2 entries exists in DNS tab: intranet_host.my_domain.com ipv6 fdcb:xxxx:xxxx::acxx:xxxx 97 intranet_host.my_domain.com ipv4 fdcb:xxxx:xxxx::acxx:xxxx 97

To be noted in both cases these are inappropriate address family used. I opened a bug on mozilla for this: https://bugzilla.mozilla.org/show_bug.cgi?id=1174249

  • 1
    Welcome to Super User! This is really a comment and not an answer to the original question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – DavidPostill Jul 14 '15 at 19:49
  • 3
    I have finally found a way to solve the the issue without having to restart firefox: Settings network.proxy.socks_remote_dns;true made firefox to send again DNS requests. Subsequent resettings to default did not bring back (for the moment) to DNS silent status. – tudor Jul 15 '15 at 14:09
  • 1
    Great. You should edit your answer and add the information about the solution from your comment ... ;) – DavidPostill Jul 15 '15 at 14:14
  • Changing network.proxy.socks_remote_dns to 'true' finally did the trick for me. – SturdyErde May 16 '18 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.