1

I downloaded VirtualBox to a windows 8.1 machine by selecting the Windows (32-bit/64-bit) installer option at this link on the Oracle web ste. But when I try to create a new Virtual Machine using resulting VirtualBox, all of the Linux options are 32 bit.

How can I get VirtualBox to set up a 64 bit CentOS 7 virtual machine? Do I need to download a different installer? Or is the problem that I am not using this installer correctly?

  • Is your host OS 64 bit? You need a 64 bit host OS and the 64 bit version of VirtualBox in order to run 64 bit guests. – heavyd Jun 19 '15 at 19:28
  • @heavyd I am pretty sure my host OS is 64 bit. It is Windows 8.1 in its default configuration. – CodeMed Jun 19 '15 at 19:29
  • You can check by searching for "System" in the control panel (or Win Key + Pause/Break). The system properties screen will tell you if you have 32-bit or 64-bit. – heavyd Jun 19 '15 at 19:32
  • @heavyd The host OS is 64 bit. – CodeMed Jun 19 '15 at 19:35
2

Assuming you have a 64-bit CPU, then one would need to enable VT-x/AMD-v in the BIOS of the host computer. After enabling the virtualization features in the BIOS, VirtualBox can be obtained from www.virtualbox.org.

  1. VirtualBox 4.3.28 for Windows hosts x86/amd64
  2. Also install the Extension Pack after installing VirtualBox.

I don't know if the feature for installing a 64-bit guest will just appear in VirtualBox after enabling virtualization. Maybe a re-install might be needed.

  • That is documented with your hardware manual. Often, it's pressing F2, DEL, or F10 as the computer first starts up. The exact procedure and language are specific to the hardware. It might even tell you as you boot up. – Christopher Jun 19 '15 at 19:36
  • BIOS. Yes. VT-x and AMD-x are the names of the technologies for Intel and AMD, respectively. The BIOS may or may not explicitly identify the technology by those names. The language is specific to the BIOS. Once you find the right option to enable, you exit the BIOS saving changes. These options should be documented in the mobo manual if it seems that it's too vague to discern without the manual. – Christopher Jun 19 '15 at 19:50
  • Oh - you might not have a BIOS. You might have UEFI (the "new BIOS", so to speak.) Same thing for this purpose. What's the mobo or PC make/model? – Christopher Jun 19 '15 at 20:20
  • 1
    The solution was to power up, click escape to interrupt booting, select boot options from the resulting menu, navigate to the boot configuration menu, and then enable "Virtualization Options", which must be an abstraction of various things including VT-x and AMD-x. In any event, the result is that now I can choose 64 bit RHEL in VirtualBox to hopefully create a CentOS installation within windows 8.1. I will mark this as answered and +1. If another subsequent problem arises, I will just post another question. Thank you again. – CodeMed Jun 19 '15 at 20:28
  • \o/ You do well. – Christopher Jun 19 '15 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.