25

I guess there no need to introduce the "Privacy error" page in Chrome that appears whenever one uses SSL to access an uncertified website that has no signed certificate (red "X" on the lock icon).

Thing is, I use SSL to access numerous personal locations which I vouch for and know for a fact they're OK (they're mine). Since I'm visiting those location more than once a day, I'm forced to go through two clicks before I enter the website and that's tedious.

Is there a way add an "exception" specifically for this matter, for specific websites (a white list essentially)? Any other way of achieving this is of course more than welcomed.

Thanks!

  • 1
    Are you aware of letsencrypt who will give you free SSL certificates? That won't work if it's for sites on an internal network though. – Mikael Kjær Nov 24 '16 at 10:42
  • I've heard of it. Do you mean that it would not work for LAN resources like NAS devices and/or home servers? – voronoi Dec 5 '16 at 8:58
  • Only if it has an external hostname with a valid TLD, like mydomain.com – Mikael Kjær Dec 5 '16 at 10:15
  • 2
    I've been beating my head against this. I don't care about the sites security, its just a testing site. Chrome is just playing it too hard. In Firefox you just click one button to ignore the error for a particular site, and that's that. I concluded I'm better of using Firefox than rather than waste a few more hours making Chrome happy with a bad certificate about which I don't really care. – Kris May 18 '18 at 0:39
6

I don't believe there is per-website setting that specific in Chrome.

If you have, or can get an SSL certificate, you may be able to copy your certificate directly into Chrome's certificate store, and mark it as Trusted Root. Navigate to "Settings > Advanced > HTTPS/SSL > Manage Certificates..." to import it. See Getting Chrome to accept self-signed localhost certificate for more information about how to do this.

Alternatively, you can try to add the site to your Trusted Sites list (located in "Control Panel > Internet Options > Security tab") which may alleviate the error. Be sure to untick the "Require server verification (https:) for all sites in this zone" checkbox.

  • With the second solution you offered, are you sure you were referring the Chrome? I couldn't find a security "tab" (the Chrome control panel is not tabbed) anywhere, but I might be doing something wrong. – voronoi Jun 20 '15 at 16:03
  • Sorry. Internet Options is located in the Windows Control Panel. – Floofies Jun 20 '15 at 16:07
  • 2
    Hi, I tried everything described in that discussion (that is relevant), and nothing worked. Maybe the solutions offered there a outdated, and versions of Chrome released since require a different approach? – voronoi Jun 30 '15 at 8:14
3

You must create a self-signed certificate, and have the SAN (Subject Alternative Name) element configured within the certificate for the appropriate server name. Then import the certificate into Chrome, giving it "Trusted" status. Without the SAN element configured properly, errors will still occur.

  • 1
    @Mitch, this sounds exactly like what I'm looking for. Is there any guide that describes how to do this? – voronoi Oct 15 '17 at 5:10
  • The procedure varies, dependent upon the OS one uses. A few simple searches should bring up the procedure for a particular OS. One can use an "online generator" as well, but the SAN is usually not colinfigurable, and thus produces varying results once imported into the browser's security store and marked as 'trusted". Mobilefish Generator SSLChecker Generator – Mitch R. Oct 16 '17 at 9:44
2

Another quick option to get past this is to type in Chrome's "interstitial bypass keyword" whilst the offending page has focus. At the time of writing, this is thisisunsafe but it has changed in the past and is likely to do so in future.

The usual caveats apply - only use it if you know what you're doing. More detailed info is in the links below:-

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.