2

I have been trying to mount a virtualbox folder for some time now and keep getting

mount: unknown filesystem type 'vboxsf'

I have installed and reinstalled guest additions a number of times both from the repository and using the "insert guest addition CD" option (and then succesffully running the installer and rebooting) in the virtualbox. Does anyone by any chance have any idea what the problem might be?

I'm running Ubuntu 14.04 as both the host and the guest. And have Virtualbox 4.3.10 as far as I can tell. Everything should patched and updated to the latest version.

Edit:

mount -t vboxfs sharename local_directory_name

  • Can you edit to show the full mount command you're using? Have you shared the directory you're trying to mount from the host side? When you say "insert guest addition CD", you then successfully ran the install scripts located on the (virtual) CD, right? – Ash Jun 23 '15 at 8:12
  • @ash I editied, Yes I have shared it on the host side using the shared folders setting in virtualbox, Yes I did succesfully run the scripts (or at least the scripts claimed they ran succesfully). – DRF Jun 23 '15 at 8:17
1

Curiously, just tried the same thing with Kubuntu 14.04 (host) on Mint 17.1 (guest), and got the same error.

The fix was to do this (as per this post):

sudo ln -f -s /opt/VBoxGuestAdditions-4.3.10/lib/VBoxGuestAdditions/mount.vboxsf /sbin/mount.vboxsf

Then manually add your user to the vboxsf group (as per dot point 2 in this answer):

sudo usermod -a -G vboxsf <username>

Reboot the guest, and then try the mount command again:

sudo mount -t vboxsf <share name> <mount dir>
  • Thank you. I've now managed to move from the "unknown file system message" to the "no such device" error. I checked that I'm in the correct group and that the link I'm creating actually exists but still no go.:( – DRF Jun 23 '15 at 9:26
  • I'm seriously starting to consider just using samba.:( – DRF Jun 23 '15 at 9:32
  • May not be able to help much more as I can't reproduce that problem. There are quite a few suggested fixes for that error around the net though. Maybe have a look at superuser.com/questions/725240/… and stackoverflow.com/questions/3492466/…, see if any of the suggested fixes help? – Ash Jun 23 '15 at 9:47
1

Having combed through many forum and discussion threads I ended up eventually solving the problem ... it seems to be a bug with the 4.3.10 version under (atleast) Ubuntu 14.04 which makes it impossible for the appropriate kernel modules to actual compile (didn't find it discussions originally though only found out checking logs) the solution seems to be to upgrade to 4.3.28 which available from oracles repository as a deb package. You can find it here. After upgrading and reinstalling guest additions everything seems to work fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.