I have been spending the last 4 hours trying to get my VNC connection to work. Eventually, I realized it was because my Ubuntu remote host was unable to host SSH connections- even though I had already installed openssh-server.

I then tried some basic tests to verify that sshd was working on my machine, and found that ssh localhost gives a Connection refused on port 22 error. Also, sudo service ssh start and sudo start ssh both give a start: Unknown job: ssh error. I tried purging and reinstalling openssh-server, but no luck. Why can't I receive clients?

  • Do you have an '/etc/init/ssh.conf' file? – edumgui Jun 23 '15 at 7:25
  • @Santeador Yes. – James Ko Jun 23 '15 at 7:27
  • An it doesn't even start rebooting? – edumgui Jun 23 '15 at 7:31
  • Try from a shell pgrep -l sshd. It should answer with the PID and sshd (something like 1379 sshd). If not, run manually sshd and check it again with pgrep -l sshd and with ssh localhost. – Hastur Jun 23 '15 at 7:50
  • the ssh service is sshd, not ssh. try sudo service sshd start – Russell Uhl Jun 23 '15 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.