0

I'm running Windows Vista SP2 and I recently got a problem that is quite urgent. I cannot install drivers on my system. When I run (for example) driver executable, an error pops up saying "Driver Installation Module has stopped working". Everytime when I boot up, I also get a window: Windows needs to install drivers for Unknown Device. "Locate and install driver software" option doesn't work. It points me to the Driver Wizard and the same thing happens again.

I first noticed this problem when I was installing Nvidia Drivers. Same thing happened (back then it was the first time).

At first I thought that there's a virus/malware/trojan blocking the installation or something. So I tried a bunch of anti-virus/malware programs and fixing tools:

  • Avast!
  • Malwarebytes Anti-Malware
  • Anti-Rootkit programs (something from Kaspersky Labs, I dont remember)
  • Hitman-Pro
  • Tweaking.com Windows Repair Tool
  • tried sfc /scanall, repaired some files, but not drvinst.exe (if that's the problem)
  • completed chkdsk

None of them solved the problem.

Please help as I cannot install any drivers and it's frustrating. Thanks in advance, Simon

My PC specs:

  • Windows Vista Home Premium (64x)
  • 12GB RAM
  • Nvidia GeForce GTX 570
  • Intel Core i7 (2.67 GHz)

My first post :D

UPDATE: Things are getting interesting. Now, after clicking "Locate and install driver ....", I get a nortification in tray saying "device drivers have been sucsesfully installed" (in case of usb), BUT the usb doesn't show up in Explorer. Weird. Device manager says that everything is ok. Any ideas?

  • drvinst.exe sounds suspiciously like the app you'd need to install drivers… can you copy it over from a working machine – Tetsujin Jun 23 '15 at 16:44
  • Use MSConfig to put the computer into "Diagnostic startup" mode, reboot, try again, and post results here. – Ƭᴇcʜιᴇ007 Jun 23 '15 at 16:59
  • Sounds awfully similar to an issue I had in Win98 and WinXP way, way back then. I tried to install several drivers without rebooting between installations. When finally rebooted, couldn't install a thing. Only solution I found was to fresh reinstall OS... I know it's Vista, but... It was least successfull OS they built.... Maybe something migrated? – AcePL Jun 23 '15 at 17:23
  • @Ƭᴇcʜιᴇ007 I did that, thanks. It works. Should I try eliminating the services one by one and reboot again? – DefaultSimon Jun 23 '15 at 18:27
  • Yup. That's what I'd do anyway. :) – Ƭᴇcʜιᴇ007 Jun 23 '15 at 18:29

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.