Trying to use Wayland on Ubuntu 15.04, I followed the instructions I can find on google. I can see the gdm login screen and choose GNOME on Wayland shown as below. But after I type in my password it goes back to login screen again. I'm pretty sure I type in the right password.

I have tried both ona VM and my actual machine, they have the same result.

Any idea?

Platform: ubuntu-15.04-desktop-amd64


$ sudo add-apt-repository -y ppa:wayland.admin/daily-builds
$ sudo apt-get update
$ sudo apt-get install xwayland weston
$ sudo apt-get install gnome-session-wayland
$ sudo apt-get install gnome-shell


How to Install Latest Wayland in Ubuntu 14.04 Gnome via PPA

Now You Can Easily Install And Test Wayland On Ubuntu 15.04 And Ubuntu 15.04 GNOME

enter image description here

  • @fixer1234 Yeah, actually you're right. It probably should be renamed just wayland.
    – Insane
    Oct 27 '15 at 3:33

see brute way:

Try Update first: https://gist.github.com/wellington1993/44def31e824d0b7a45fe14609738e696

The first link is to update the system to latest state.

and after install with dependencies: https://gist.github.com/wellington1993/1e3c2f7254b1a372c3158b15c125e3f7

The second is more detailed Way to install dependencies.

NOTICE: But I'm think the Wayland is for more updated Ubuntu and not recommend for versions below 17.10

  • I can't solve with this solution when tried to install in Linux Mint the Waylant environment. Oct 24 '17 at 2:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.