I have a modern PC (Quad Core CPU, 4 GB RAM, Win7 Home Premium 64-bit) but I have a problem with burning .dvd images to Double Layer (8.5 GB) DVDs. I wasted too many DVD+R DL discs but to no avail. Here is a short explanation of what I did:

I'm using ImgBurn v2.5.0.0 (latest version). I'm trying to burn an image file (.dvd) which is together with the related .iso file in the same folder. In ImgBurn, I select the file with .dvd extension, and set writing speed to 2.4x. Burning process starts normally, but around 7% of the process, it gives a I/O Write Error, which is as follows:

enter image description here

I wasted 3 discs (Magic, Made in Taiwan, DVD+R DL, 8.5 GB) trying the same thing. My DVD writer is LG GH22NP20 with IDE connection type. I updated its firmware from 1.04 to 2.00 but no success in burning again. Then my cousin brought his LG (an older model) which, he claims, was successful in writing DL discs with the same brand (Magic). I plugged off my LG and plugged the older one in, and tried to burn the image again. It also gave an I/O Error even without standing till 7%. I tried another burning program (CloneCD), but failed again.

Then I bought other brands (TDK and VERBATIM) and tried to burn the image. Burning process started successfully, but around 14% (for Verbatim) and 25% (for TDK) failed again. Here is a screeny from ImgBurn:

enter image description here

I've burned lots of 4.7 GB DVD+Rs and DVD-Rs successfully, even without a single error, with this LG DVD writer, but this case is very bothering for me. What should I do? Should I buy a new DVD writer other than LG? Could this be related to Windows or my hardware configuration? Thanks for your help.

Edit: My burner works on my cousin's machine. So the problem must be related to my system. What could be the reason?

Latest news: I borrowed an external USB DVD writer from a friend, which is PHILIPS SPD3000CC (an old model). Guess what! It's burning DVD+R DLs successfully! How come an internal DVD writer of a brand new computer system cannot burn DL DVDs? Now I'm considering buying a new internal DVD writer with not IDE, but SATA connection...

Bottom Line: I've sold this PC and probably never gonna learn the answer to my question.

  • update the firmware of your burner.
    – Molly7244
    Jan 28, 2010 at 19:36
  • @Molly: I've already done it. Please read the 3rd paragraph of my question. Jan 28, 2010 at 20:07
  • your cousin using a 64-bit OS?
    – Molly7244
    Jan 28, 2010 at 20:19
  • Yes he is. Win7 64-bit. I think the problem comes from my motherboard or drive cables or something physical like those. As I stated, external USB DVD writer works OK on my system... It is also strange that I have no problems with single layer DVDs. Jan 28, 2010 at 20:31

1 Answer 1


It could be an issue with the drive controller it is plugged into, or it could be an issue with Windows. Did your cousin use Windows 7 to burn DL discs? Also, have you tried your burner in your cousin's computer?

Reinstalling Windows may help, but there is no way to know until you try.

  • My cousin also uses Windows 7. I didn't try my burner on his machine. I can try it to understand if the problem comes from the burner or not. Thanks for your answer. Jan 8, 2010 at 19:59
  • My burner works on my cousin's machine. So the problem must be related to my system. What could be the reason? How can I fix the drive controller? Jan 15, 2010 at 7:55
  • You can try uninstalling the driver for the burner and drive controller in Device manager, then restarting to get it to reinstall. If that still doesn't work, to replace the drive controller, you most likely would have to get one that plugs into a PCI slot, or replace the motherboard. Most motherboards have on-board drive controllers. Jan 19, 2010 at 17:39
  • I uninstalled and reinstalled driver, but to no avail. Jan 28, 2010 at 19:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.