Note: the problem changed now. You can read the "Old Problem" if you want, but it's not needed to understand the new one.

New Problem

With a lot of hackery (extracting the .msi's and then Orca) I finally managed to install the Mobile Device Support thingy, and that fixed the old problem. However, another problem arose.

Basically, iTunes won't recognize my iPhone when it's not in DFU or recovery mode. I made the mistake of trying to recover it (by rebooting it in DFU mode so that it gets recognized, and then clicking restore); but as soon as the iPhone reboots itself into normal mode to install the firmware iTunes hangs.. So now I'm stuck with an unusable iPhone for the time being! :( (since the recovery process formatted it, but now I can't install the firmware)

I got tired of it and figured it would be faster to create a 32 bit Windows XP VM than to resolve the problem. Curiously enough, Windows XP has the same exact problem. I tried several times; what's interesting is that it gets stuck at different times (sometimes at waiting for iPhone, sometimes at reinstalling iphone software 1 tick, sometimes 2 ticks, etc)..

Any ideas? This is what I'm going to do as soon as I'm able:

  • Try with a different USB cable
  • Try with a different computer

Old Problem

I use Windows 7 x64 and, after a format, I installed the x64 version of iTunes. (iTunes.exe appears to be 32 bit though from the task manager, but I've been told below by Randolph Potter (below) that this is normal; however can anyone else confirm that?)

After I plug in my iPhone in all its radiant wisdom it says:

This iPhone cannot be used because the required software is not installed. Run the iTunes installer to remove iTunes, then install the 64-bit version of iTunes.

This is really making me mad, especially because the iTunes I installed (several times now) is x64 (and not x86, yes I am sure).

I tried googling, other people have had the same problem but didn't find any solution so far. Any ideas?



I found the problem. It's apparently tied to the motherboard (I have a P7P55D)..

Gigabyte has issued a BIOS upgrade that fixes it; unfortunately mine is Asus so I guess I have no choice but wait.

  • Is it a new iPhone, or did you already synch it with your PC before the re-install? – Martin Jan 11 '10 at 8:36
  • @Martin: I already synched it several times. I actually can't remember if the last time was with windows 7 RTM or a beta, 99% sure it was RTM. Anyways, since this last time I reformatted and never had to sync again until now (been a few months at least), so I never reinstalled iTunes. – Thomas Bonini Jan 11 '10 at 8:38
  • Just as a side, I don't know how the recent versions of iTunes works, but on my office computer, the person before me had installed an old version of iTunes, and after I removed it, there were still components left that I had to clean out. You might look into what is left over in terms of registry keys and configuration files if you're comfortable digging into the operating system. – Tom A Jan 13 '10 at 17:52

In the thread Do iPods work with 64 bit Windows 7 one participant says:

I would uninstall iTunes from your computer, reboot and download a fresh copy of the 64 bit version of iTunes version 9. Install that and reboot...Now add your music library back into iTunes and then pair your ipod with iTunes (it will wipe and resync your ipod so be sure you have your mucis/data from your ipod backed up.

My remark: I would suggest in that case using Revo to uninstall iTunes completely.

Another participant in the same thread also says:

This may sound overly simplistic but before you spend a large amount of time troubleshooting this try a different cable.

After trouble shooting Windows 7 64bit for over a week with multiple versions of ITunes across 2 different Dell laptops I got frustrated and out of desperation decided to replaced my Apple usb cable with a Griffin USB cable. Guess what, the new cable worked like a champ on both laptops with Windows7. I am a bit baffled but ultimately rule 25 says "never argue with success".

| improve this answer | |
  • Unfortunately I don't have another cable to try it with.. I'll try to ask a friend, though. And when I first installed iTunes my pc has been formatted a few days before, so I don't think Revo will help. :/ – Thomas Bonini Jan 11 '10 at 9:38
  • Revo will help to ensure that you do a clean installation. Most software uninstallations leave stuff behind, which is why I only use Revo for that. It's possible that the first installation left something behind that new installations leave as-is. – harrymc Jan 11 '10 at 9:58
  • I finally managed to try with revo, same problem – Thomas Bonini Jan 13 '10 at 15:23
  • All that is left to try is (1) another cable (2) doing the same but in XP Mode. – harrymc Jan 13 '10 at 15:42
  • Well I tried 2, now I'll try 1..... Crossing fingers. (PS: see edit) – Thomas Bonini Jan 14 '10 at 0:54

I suggest you to install iTunes x86 even if you have Windows 7 x64. I have heard that iTunes x64 have some compatibility problems. Just give it a try.

| improve this answer | |
  • It won't work with iPhones. And actually (see my edit) it installed x86 instead of x64, for some reason, and that turns out to be the problem. No matter what I do it keeps installing x86 – Thomas Bonini Jan 8 '10 at 16:10
  • I can't say I've experienced this problem. At any rate, the installer is the only part that is 64-bit - iTunes itself is still 32-bit. I have Windows 7 Ultimate x64 and 32-bit iTunes. – user3463 Jan 8 '10 at 17:44

When did you download iTunes? Are you sure that this isn't a leftover download from a few months ago? iTunes was recently updated for x64, and it's possible that you might have a earlier x64 version that had a bug?

Check out this thread... Windows 7 & itunes Install Probably not relevant at this point... After all it's from early in 2009... But..

| improve this answer | |
  • Yes, I am sure, I just downloaded it! – Thomas Bonini Jan 8 '10 at 21:16

Regarding your answer on my original comment: Maybe you can make a complete backup of your iPhone with a different PC/iTunes, then reset the iPhone, restore the backup and synch it on your "first" PC.

| improve this answer | |
  • It's not a problem with the iPhone, it doesn't matter if it's reset or not.. It shows that error before any communication between the two takes place – Thomas Bonini Jan 11 '10 at 8:57
  • But the error is only shown when you plug it into the computer, isn't it? I thought of a complete factory restore wich resets the iPhone to the delivery status. – Martin Jan 11 '10 at 9:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.